Bug 183724 - Installation fails on IA64 platform.
Installation fails on IA64 platform.
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda-product (Show other bugs)
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Depends On:
  Show dependency treegraph
Reported: 2006-03-02 22:06 EST by Ashwin
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: u3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-03-13 10:41:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Bug report file (1.24 KB, text/plain)
2006-03-02 22:06 EST, Ashwin
no flags Details
lspci -vvn output from failing system (29.34 KB, text/plain)
2006-03-03 15:17 EST, Bruce Vessey
no flags Details

  None (edit)
Description Ashwin 2006-03-02 22:06:21 EST
Created attachment 125579 [details]
Bug report file
Comment 1 Ashwin 2006-03-02 22:06:21 EST
Description of problem:
Installation of RHEL U3 RC on IA64 stalls just before it goes to format the
disks to install the OS. The GUI install fails but the text mode install
succeeds.I got a dialog box asking it to be reported as a bug in bugzilla with
the following text.

------------Start of bug report text--------------------------
Exception Occured:


An unhandled exception has occurred. This is most likely a bug. Report it to


Traceback (most recent call last):

File "/usr/src/build/711711-ia64/install/usr/lib/anaconda/gui.py", line 1074 in


File "/usr/src/build/711711-ia64/install/usr/lib/anaconda/iw/progress_gui.py",
line 242, in renderCallback


File "/usr/src/build/711711-ia64/install/usr/lib/anaconda/gui.py", line 789, in


File "/usr/src/build/711711-ia64/install/usr/lib/anaconda/dispatch.py", line
171, in gotoNext


File "/usr/src/build/711711-ia64/install/usr/lib/anaconda/dispatch.py", line
239, in moveStep


File "/usr/src/build/711711-ia64/install/usr/lib/anaconda/packages.py", line
570, in turnOnFilesystems


File "/usr/src/build/711711-ia64/install/usr/lib/anaconda/fsset.py", line 1442,
in createLogicalVolumes


File "/usr/src/build/711711-ia64/install/usr/lib/anaconda/fsset.py", line 2061,
in setupDevice

raise SystemError,"lvcreate failed for %s" %(self.name,)

SystemError: lvcreate failed for LogVol00

-------------------- End of bug report text -----------------------------------


Version-Release number of selected component (if applicable):
RHEL 4 Update 3 RC

How reproducible:

Steps to Reproduce:
1. Use CD install in GUI mode
2. Select default file system creation as given by the installation
3. Select DHCP for configuring the ethernet card
4. Select default Software to be installed
5. The next display is the dailog box with the above text in the Description text
Actual results:
1.Installation unsuccessful using a GUI install.
2.Text mode install is successful.

Expected results:
GUI and text mode installation should be successful.

Additional info:
Running on ES7000 servers.
Comment 2 Bruce Vessey 2006-03-03 10:22:00 EST
This is occurring on an ES7000/400 system.  So far, it appears to be 100% 

This is during a GUI install.  Text mode install works ok.  (We haven't tried 
VNC yet.)

Please note that the install worked successfully on RHEL 4 U3 beta 2.  This 
failure is on RC3.
Comment 3 William Jordan 2006-03-03 11:58:31 EST
This does not appear to be at all related to Bug 183683. This appears to be a 
logical volume issue on the ia64 release.

The VNC install with default partitioning failed the same way.

However, if we delete all the partitions (including all Logical Volumes) 
before installing, and we specify no logical volumes during the install, the 
GUI install works successfully.

Comment 4 Ashwin 2006-03-03 12:22:25 EST
Text mode install works even with the Logical Volumes (Logical Volumes that were
created with default partitioning). 

VNC install fails exactly the same way as the GUI install with the same error
Comment 5 Bruce Vessey 2006-03-03 15:15:46 EST
This morning David Aquilina requested the lspci -vvn output from this system.  
I'm attaching that output.
Comment 6 Bruce Vessey 2006-03-03 15:17:28 EST
Created attachment 125619 [details]
lspci -vvn output from failing system
Comment 12 Bruce Vessey 2006-03-13 09:31:15 EST
We tried this again with the final, released bits of RHEL 4 U3 and can no longer
reproduce the problem.  Not sure why the behavior changed.  This bug can be closed.
Comment 14 Peter Jones 2006-03-17 14:32:12 EST
Removing from the RHEL4U4 proposed list since this bug is CLOSED.

Note You need to log in before you can comment on or make changes to this bug.