Bug 183736 - cannot input characters in windows prepared by tk (wish)
cannot input characters in windows prepared by tk (wish)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: iiimf (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-03 03:06 EST by Takanori MATSUURA
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-22 13:36:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Takanori MATSUURA 2006-03-03 03:06:56 EST
Description of problem:
In ja_JP.UTF-8 locale, we cannot any text in the windows prepared by tk (wish).

How reproducible:
everytime

Steps to Reproduce:
1. run "env LANG=ja_JP.UTF-8 /usr/share/tk8.4/demos/rolodex"
2. mouse focus to the input area
3. type characters
  
Actual results:
Not showing any characters

Expected results:
Showing characters as you type

Additional info:
This occurs in FC3 and not in FC4
"env LANG=C /usr/share/tk8.4/demos/rolodex" works fine.
Comment 1 Takanori MATSUURA 2006-03-08 21:23:00 EST
I changed component to iiimf because I solved it as the following.

In the file /etc/X11/xinit/xinput.d/iiimf, XIM should be set as
  XIM=httx
But now set as
  XIM=htt
Is this typo?

I strongly think this bug also affects in RHEL4 because RHEL4 is based on FC3
and should be fixed.
Comment 2 David Cantrell 2006-03-22 13:36:07 EST
FC3 is no longer supported by the Fedora Project.  You may want to check the
Fedora Legacy Project if you need this issue resolved in FC3.

FC5 has just been released and uses SCIM instead of IIIMF, so I'm not sure if
this bug applies anymore.  See the release notes:

http://fedora.redhat.com/docs/release-notes/fc5/#sn-I18n

If this is a problem for your RHEL3 or RHEL4 systems, please contact your
support representative at Red Hat.

Note You need to log in before you can comment on or make changes to this bug.