Bug 183737 - Three prompts to open keychain on starting nm-applet
Three prompts to open keychain on starting nm-applet
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
: Desktop
Depends On: 198921
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-03 04:04 EST by Miles Lane
Modified: 2009-01-08 23:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-08 23:33:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Miles Lane 2006-03-03 04:04:46 EST
Description of problem:

When I boot my machine and nm-applet starts, I get three identical dialogs
popping up asking me to unlock the Gnome keychain.  I have two APs.  I connect
to one with a WPA2 passphrase and the other with WEP passphrase.  It seems to me
that I should only be getting one prompt.

Version-Release number of selected component (if applicable):
NetworkManager-0.5.1-18.cvs20060301

How reproducible:
Boot my machine and wait for nm-applet to start.
  
Actual results:
Three keychain popups.

Expected results:
one keychain popup.

Additional info:

Please let me know if you need a config file, etc.  I looked around but haven't
found the file that saves my AP info (which ones require opening a keychain) in
any of the config files.
Comment 1 Pierre Ossman 2006-04-12 04:13:34 EDT
Any work being done on this? It's very annoying.
Comment 2 Zack Cerza 2006-07-21 13:27:05 EDT
Assigning to FC5. I'm also seeing this, but instead of three, it's two prompts.
Comment 3 Alex Lancaster 2008-03-02 04:49:29 EST
Still get this in F-8, sometimes 3, sometimes more.  Sometimes I have to kill
the keychain daemon.
Comment 4 Tim Wegener 2008-06-06 22:49:38 EDT
I had a similar problem in Fedora 8, where I would have to close the first
keyring prompt dialog (without entering the keyring password) and then entering
the password when the dialog reappeared worked. 
Setting up and using a new account with a new home directory made this problem
go away (it only prompts me for keyring password once when attempting to log on
to the network). 
The behaviour in Fedora 9 is a lot nicer and doesn't prompt me at all. 
Comment 5 Bug Zapper 2008-11-26 01:55:53 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2009-01-08 23:33:56 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.