Bug 183738 - Behaviour on Failure (Installer doesn't switch to console)
Behaviour on Failure (Installer doesn't switch to console)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-03 04:06 EST by Juergen Bullinger
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 13:17:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juergen Bullinger 2006-03-03 04:06:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 2.0.50727)

Description of problem:
I tried to update my fc5 test2 system with test3. I got a transaction error during install (I file this separately). The installer displayed a message dialog saying that the insall didn't work. After confirming "ok" halt was executed. But the console didn't switch to console 1 instead console 6 or 7 was displayed. This console was just black and didn't display the message that the system was halted and it is save to reboot. For some users with less experience this looks like the system just hangs.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install fc5 test3
2. simulate a bug during transaction test
3. confirm the error message
4. wait 
  

Actual Results:  The system halts (this is okay), but it shows the wrong console window

Expected Results:  The installer should automatically switch to the console which displays the messages which are printed by "halt", otherwise the user doesn't know what happened

Additional info:
Comment 1 Chris Lumens 2006-03-10 16:53:49 EST
Which error dialog was it?  Was it the generic exception dialog with "Save to
disk | Debug | OK" on the bottom, or was it a different dialog?  If it's a
different dialog, what was the text displayed in it?
Comment 2 Juergen Bullinger 2006-03-22 05:21:09 EST
Sorry I don't remember the precise error message, but I think this is a general
problem. Whenever the install fails and the system has to go down to halt the
installer should switch to the console on which the message "system halted" is
displayed.
Fedora Core has realy come far in user friendlyness. But you can't rely on the
knowledge of the users. Someone who hasnt ever used Linux will be able to
install Fedora Core, but he most likely doesn't know how to switch to the
console and maybe he also doesn't know how long it takes to shutdown a linux
based system, of if he needs to do something to shut it down if there are no
messages with instructions. I think switching to the console would help.
Comment 3 Chris Lumens 2006-06-02 13:50:52 EDT
Can you reliably reproduce this in Rawhide?  I've seen it only sporadically, but
not for a while now.  Haven't been able to figure out a pattern to it yet.
Comment 4 Chris Lumens 2006-08-14 13:17:55 EDT
I am no longer able to reproduce this in Rawhide.  Feel free to reopen if you
are still seeing this problem.

Note You need to log in before you can comment on or make changes to this bug.