Bug 1837860 - The graph is not shown after clicking "Show Graph"
Summary: The graph is not shown after clicking "Show Graph"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.5.0
Assignee: Andrew Pickering
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-20 07:09 UTC by Junqi Zhao
Modified: 2020-07-13 17:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:40:02 UTC
Target Upstream Version:


Attachments (Terms of Use)
The graph is not shown after clicking "Show Graph" (11.44 MB, image/gif)
2020-05-20 07:09 UTC, Junqi Zhao
no flags Details
Verification screenshot (2.15 MB, video/quicktime)
2020-05-25 03:21 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5515 0 None closed Bug 1837860: Monitoring: Fix Show / Hide Graph behavior for zoomed graphs 2020-06-24 03:08:38 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:40:22 UTC

Description Junqi Zhao 2020-05-20 07:09:59 UTC
Created attachment 1690085 [details]
The graph is not shown after clicking "Show Graph"

Description of problem:
Goto "Monitoring -> Metrics", search metrics, for example: cluster:container_cpu_usage:ratio
zoom in the graph, then click "Hide Graph", after a few seconds, click "Show Graph", the graph is not shown

Note: no such issue if select timespan from the timespan drop-down list

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-19-041951

How reproducible:
always

Steps to Reproduce:
1. See the description
2.
3.

Actual results:
the graph is not shown

Expected results:
no error

Additional info:

Comment 1 Robb Hamilton 2020-05-20 18:11:21 UTC
Lowering severity since the bug only occurs if the graph is first zoomed.

Comment 4 XiaochuanWang 2020-05-25 03:21:36 UTC
Created attachment 1691676 [details]
Verification screenshot

Comment 5 XiaochuanWang 2020-05-25 03:22:23 UTC
Attached the screen recording.
Verified on 4.5.0-0.nightly-2020-05-24-191212

Comment 6 errata-xmlrpc 2020-07-13 17:40:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.