Bug 1837881 - Inappropriate explain in apiserver operator command line help
Summary: Inappropriate explain in apiserver operator command line help
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.0
Assignee: David Eads
QA Contact: Ke Wang
URL:
Whiteboard:
Depends On:
Blocks: 1840479
TreeView+ depends on / blocked
 
Reported: 2020-05-20 08:21 UTC by Ke Wang
Modified: 2020-07-13 17:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1840479 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:40:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-kube-apiserver-operator pull 866 0 None closed bug 1837881: remove humorous help from dev focused command 2021-01-27 14:40:48 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:40:56 UTC

Description Ke Wang 2020-05-20 08:21:40 UTC
Description of problem: 
Inappropriate explain in apiserver operator help, see below explain for resource-graph parameter of apiserver operator command line help,
"resource-graph Where do resources come from? Ask your mother."

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-19-011623

How reproducible:
always

Steps to Reproduce:
1. run cluster-openshift-apiserver-operator and  cluster-kube-apiserver-operator with --help in related operator pod"

Actual results:

$ oc exec -n openshift-apiserver-operator openshift-apiserver-operator-865c46cb7c-j529l -- cluster-openshift-apiserver-operator --help
...

Available Commands:
  help           Help about any command
  operator       Start the Cluster openshift-apiserver Operator
  resource-graph Where do resources come from? Ask your mother.
...

$ oc exec -n openshift-kube-apiserver-operator kube-apiserver-operator-fbb978bcb-zc5x2 -- cluster-kube-apiserver-operator --help
...

Available Commands:
  cert-regeneration-controller Start the Cluster Certificate Regeneration Controller
  ...
  render                       Render kubernetes API server bootstrap manifests, secrets and configMaps
  resource-graph               Where do resources come from? Ask your mother.
...

Expected results:
Give a appropriate explain for resource-graph of apiserver operator command line.

Comment 5 Ke Wang 2020-05-27 02:43:28 UTC
Verified with OCP 4.5.0-0.nightly-2020-05-26-224432, 

$ oc exec -n openshift-kube-apiserver-operator kube-apiserver-operator-868cb75df8-jkhrl -- cluster-kube-apiserver-operator --help
OpenShift cluster kube-apiserver operator

Usage:
...
  resource-graph               Provides an often out-dated snapshot of where resources come from.

We can see the bug has been fixed on kube-apiserver component, but still found on openshift-apiserver component, will clone one bug against it.
  
$ oc exec -n openshift-apiserver-operator openshift-apiserver-operator-667ff4474f-x858t -- cluster-openshift-apiserver-operator --help
OpenShift cluster openshift-apiserver operator

Usage:
...
  resource-graph Where do resources come from? Ask your mother.

Comment 6 errata-xmlrpc 2020-07-13 17:40:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.