Bug 1838083 - Ironic: Allows users to configure any non-link-local IPV6 address for the provisioning interface
Summary: Ironic: Allows users to configure any non-link-local IPV6 address for the pro...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Bare Metal Hardware Provisioning
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.z
Assignee: Julia Kreger
QA Contact: Daniel
URL:
Whiteboard:
Depends On: 1833385
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-20 12:56 UTC by Stephen Benjamin
Modified: 2020-06-30 17:55 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Ironic containers in OCP would fail to start if the user defined "PROV_IFACE" interface was configured for IPv6 but to only use link-local addressing as opposed to a globally routable addressing. Consequence: Ironic containers would fail to start. Fix: The container start-up script has been modified to accept link-local addressing in addition to global addressing. Result: Containers will now start the interface definedby "PROV_IFACE" only contains link-level addresses as opposed to globally routable addresses.
Clone Of: 1833385
Environment:
Last Closed: 2020-06-29 15:33:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift ironic-image pull 79 None closed [release-4.4] Bug 1838083: Allows users to configure any non-link-local IPV6 address for the provisioning interface 2020-07-01 01:06:17 UTC
Red Hat Product Errata RHBA-2020:2713 None None None 2020-06-29 15:34:11 UTC

Description Stephen Benjamin 2020-05-20 12:56:32 UTC
+++ This bug was initially created as a clone of Bug #1833385 +++

Description of problem:

When using routable IPv6 addresses for the provisioning network. The previous grep command only matched local unicast addresses, this new grep will match any IPv6 address, but the link local scope.

The httpd container keeps waiting for "PROV_IFACE" to be configured otherwise.

Version-Release number of the following components:

openshift-baremetal-install 4.4.0-0.nightly-2020-05-07-005846
built from commit fb65b95076665c794e7c1cc148f56722761d0d31
release image registry.svc.ci.openshift.org/ocp/release@sha256:4aa1a03150d5b185f0dd525d9b3fbd33d98b97a8e2b51fc068bb9a56003fe750

More info here: 

- https://github.com/openshift/ironic-image/pull/78
- https://github.com/metal3-io/ironic-image/pull/153


How reproducible:

Steps to Reproduce:
1. Use the installer to deploy an IPv6 cluster
2. Wait for the Bootstrap VM to boot it up
3. Check logs on podman image "http", it gets stuck on:


Actual results:
http container gets stuck on:
...
Waiting for ens4 interface to be configured                                                                                                                                                                                                                                                                                                                               
Waiting for ens4 interface to be configured                                                                                                                                                                                                                                                                                                                               
Waiting for ens4 interface to be configured                                                                                                                                                                                                                                                                                                                               
Waiting for ens4 interface to be configured                                                                                                                                                                                                                                                                                                                               
Waiting for ens4 interface to be configured                                                                                                                                                                                                                                                                                                                               
Waiting for ens4 interface to be configured
...

Expected results:

Additional info:

Gets the right ipv6 configured on the httpd server

Comment 8 errata-xmlrpc 2020-06-29 15:33:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2713


Note You need to log in before you can comment on or make changes to this bug.