Bug 1838427 - Unable to edit the knative service via edit forms from topology
Summary: Unable to edit the knative service via edit forms from topology
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-21 06:54 UTC by Jaivardhan Kumar
Modified: 2020-07-13 17:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:40:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5505 0 None closed Bug 1838427: fix issue with annotations on knSvc edit 2020-06-24 03:10:45 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:40:49 UTC

Description Jaivardhan Kumar 2020-05-21 06:54:30 UTC
Description of problem: Unable to edit the knative service via edit forms from topology. Annotations for Creater/last modifier are immutable now so API call fails with 400 - bad request


Version-Release number of selected component (if applicable): 4.4


How reproducible: Always


Steps to Reproduce:
1. Install OpenShift Serverless Operator
2. Create a knative service type resource
3. Try to edit that knative service type resource when revisions are up

Actual results: Unable to edit the service.


Expected results: Should be able to edit the service.


Additional info:

Comment 3 Gajanan More 2020-05-22 13:22:56 UTC
I have validated the bugzilla on
Buid: 4.5.0-0.ci-2020-05-22-080435
Browser: Google Chrome Version 81.0.4044.129
Marking this as verified

Comment 4 Gajanan More 2020-05-22 13:23:05 UTC
I have validated the bugzilla on
Buid: 4.5.0-0.ci-2020-05-22-080435
Browser: Google Chrome Version 81.0.4044.129
Marking this as verified

Comment 5 errata-xmlrpc 2020-07-13 17:40:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.