Bug 1838472 - Add button from Health checks page gets activated and clickable even though we don't add anything
Summary: Add button from Health checks page gets activated and clickable even though w...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Mohammed Saud
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-21 08:36 UTC by Sahil Budhwar
Modified: 2020-07-13 17:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:40:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5516 0 None closed Bug 1838472: Disable add button for unfilled healthchecks form 2020-06-24 03:10:52 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:40:49 UTC

Description Sahil Budhwar 2020-05-21 08:36:37 UTC
Steps to Reproduce:
1. Create a workload
2. Go to sidebar and click on the Add Health checks
3. Just open all the the health checks and don't click on 

Actual Results:
1. Add button gets activated when user opens form for any probe.
2. User can click on the ADD button even though he didn't select any probe and just opens it.

Expected Results:
The Add button should get clickable only if user selects any probe and not before that.

Additional Info:
Build: 4.5.0-0.ci-2020-05-09-014245
Browser: Google Chrome Version 81.0.4044.129

Please have a look at the screenshots and screen recording

Comment 4 Gajanan More 2020-05-29 03:50:13 UTC
I have validated the bugzilla on:
Build: 4.5.0-0.nightly-2020-05-28-070355
Browser: Google Chrome Version 81.0.4044.129
Marking this as verified.

Comment 5 errata-xmlrpc 2020-07-13 17:40:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.