Bug 1838504 - [vSphere] Fail machine on invalid provider spec values
Summary: [vSphere] Fail machine on invalid provider spec values
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Alexander Demicev
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-21 09:53 UTC by Alexander Demicev
Modified: 2020-07-13 17:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:40:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-api-operator pull 593 0 None closed Bug 1838504: [vSphere] Fail machine on invalid provider spec values 2020-06-24 03:11:00 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:40:49 UTC

Description Alexander Demicev 2020-05-21 09:53:38 UTC
When providerSpec contains non-existent "folder", "datastore" or "resource pool" machine should fail with an invalid configuration error.

Steps for QE to reproduce:
1. provide non-existent "folder", "datastore" or "resource pool" in providerSpec
2. Watch machine go to failed state

Comment 4 Jianwei Hou 2020-05-25 05:28:16 UTC
Verified in 4.5.0-0.nightly-2020-05-24-223848, machine will be Failed when the providerSpec has invalid datastore, folder and resource pool.

Comment 5 errata-xmlrpc 2020-07-13 17:40:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.