Bug 1838658 - Terminal doesn't connect to cloudshell with new backend changes
Summary: Terminal doesn't connect to cloudshell with new backend changes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Rohit Rai
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-21 14:11 UTC by Rohit Rai
Modified: 2020-07-13 17:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:40:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5428 0 None closed Bug 1838658: Use new proxy to connect to cloudshell in terminal 2020-07-03 10:07:10 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:41:14 UTC

Description Rohit Rai 2020-05-21 14:11:57 UTC
Description of problem: Latest backend changed the implementation for cloud shell terminal from iframe to pod exec.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install che workspace operator
2. Click on terminal icon in top nav.

Actual results:
Terminal doesn't connect to cloudshell

Expected results:
Terminal should connect to cloudshell

Additional info:

Comment 5 errata-xmlrpc 2020-07-13 17:40:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.