Bug 1838683 - VM Import wizard: Description field is disabled
Summary: VM Import wizard: Description field is disabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Container Native Virtualization (CNV)
Classification: Red Hat
Component: V2V
Version: 2.4.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 2.4.0
Assignee: Brett Thurber
QA Contact: Daniel Gur
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-21 15:05 UTC by Avital Pinnick
Modified: 2020-07-13 17:41 UTC (History)
11 users (show)

Fixed In Version: 2.4.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:40:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
Import VM Wizard - General screen (92.73 KB, image/png)
2020-05-21 15:05 UTC, Avital Pinnick
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github ManageIQ manageiq-v2v-conversion_host pull 64 0 None closed ovirt: fetch description 2020-06-30 13:20:30 UTC
Github kubevirt vm-import-operator pull 258 0 None closed Add vm description 2020-06-30 13:20:30 UTC
Github openshift console pull 5629 0 None closed Bug 1838683: allow description for ovirt VM Import 2020-06-30 13:20:30 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:41:14 UTC

Description Avital Pinnick 2020-05-21 15:05:06 UTC
Created attachment 1690673 [details]
Import VM Wizard - General screen

In the VM import wizard's General screen, the "Description" field is disabled.

Is this expected behavior? Is the "Description" field populated by the imported VM's metadata? Or is this field supposed to be enabled?

Comment 1 Filip Krepinsky 2020-05-22 15:07:58 UTC
We probably want to do something about this, but the discussion on what should be the expected behavior is in progress.

Comment 2 Yaacov Zamir 2020-05-25 06:09:00 UTC
setting to 4.6 since the feature is under discussion

@Filip hi, do you have some reference for the discussion we can link here for book-kipping ?

Comment 3 Filip Krepinsky 2020-05-25 13:00:58 UTC
No new info yet, but mentioned this BZ in that thread.

Comment 4 Peter Lauterbach 2020-05-26 12:36:38 UTC
A reasonable behavior is to default to using the imported VM description value in the this field, and make it editable, so it can be overridden by the user doing the import.

Comment 5 Tomas Jelinek 2020-05-29 08:21:18 UTC
did not have time to fix this one in the previous sprint, will do in the next one.

Comment 8 Ilanit Stein 2020-06-09 08:00:38 UTC
Verified on CNV-2.4.
Managed to edit & set VM description for VM import from RHV and VMware providers.

Comment 11 errata-xmlrpc 2020-07-13 17:40:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.