Bug 183871 - Install Everything option missing
Install Everything option missing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-03 04:52 EST by Lee Reynolds
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-03 11:49:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bash script to "install everything" (193 bytes, text/plain)
2006-04-17 23:41 EDT, Ronald Cole
no flags Details

  None (edit)
Description Lee Reynolds 2006-03-03 04:52:45 EST
Description of problem:

Someone has intentionally removed the Install Everything option from Anaconda.  As 
someone who is paid to support Linux, I consider this to be an act of sabotage.  

Am I to understand that I'm actually going to have to go through each and every 
individual group while doing an install and play whack-a-mole with the mouse for the 
better part of 10 minutes?  Who do I sue when I get carpal tunnel syndrome?  Who do I 
send my therapy bills to when I finally lose it after having to play one too many 
rounds of "What is that and why are we installing it?" with the professors and 
graduate students I'm paid to support?  

Am I to understand that this is supposed to be "better?"  A "feature?"

There is an old saying which tells us to never attribute to malice that which can be 
explained by stupidity.  Well I'm having a hard time telling which agent is at work in 
this case.  

If you think I'm being harsh then you need to understand that I'm having a VERY hard 
time remaining civil here.  I can't remember the last time I was filled with this much 
visceral anger.  The "Install Everything" selection is a KILLER FEATURE that sets 
Redhat/Fedora apart from other distributions.  When I do an OS install for a customer, 
I like not having to fight with the system to make sure that everything is installed.  
I like not having to worry about whether something is missing.  I like not getting 
emails months from now asking "Where is package blotto-3.5-1?"  I like not having to 
try and install package blotto-3.5-1 and play chase the dependencies.  Removing the 
ability to easily do a COMPLETE install is an unbelievably obtuse thing to do, 
especially on purpose.  I'd much prefer to be hit over the head with a crow-bar 
because at least that pain is temporary.  This pain is not and that means I now have 
to start looking at other distributions or find a way to roll my own sub distribution 
of Fedora with the install everything option enabled.  I will NOT play whack-a-mole 
just because some developer thinks that it is a good way to increase a user's 
"discovery" of the system or because they want to play word games with the meaning of 
"everything."

And please don't tell me to "just use kickstart with @ Everything" because that is a 
tremendously flippant response.  I can't use kickstart and you know why?  Because 
every single fscking machine I work on is different.  There are hundreds of systems 
where I work and while many are similar, very few are indentical.  Many newer ones 
don't have floppy drives.  The only reliable methods I have of doing an install are 
over the network starting with a standard boot CD, or off the CD's themselves.  I 
would be AMAZED if I was in the minority when it comes to this.  Besides, why should I 
HAVE to use kickstart in the first place when anaconda worked fine before now?  

Version-Release number of selected component (if applicable):
Fedora Core 5 Test 3


How reproducible:
Every time you try to do an install.

Steps to Reproduce:
1. Boot from CD
2. Begin the install process
3. Search in vain for the "Everything" option that used to be part of the package 
selection step.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2006-03-03 11:49:47 EST
Everything starts to have far less concrete meanings as we move towards
supporting multiple repositories which could well have conflicting packages. 
Already 50% of people think everything should exclude language support packages
and another 50% think that it shouldn't.  

Also, when the UI is displaying groups of packages (where each package is
explicitly listed), having a group which is magic is difficult so support and
also just doesn't fit in the the interface.

The everything install as an interactive option is not coming back.
Comment 2 Stefan Geuns 2006-03-04 05:36:30 EST
Is install everything per group an option? 
Comment 3 Jim Cornette 2006-03-10 18:47:29 EST
bug 185161 and second comment

Right click on the group, see select all and select none of the optional packages.

Comment 4 Claude Jones 2006-03-11 09:04:17 EST
I have been a vociferous advocate of reinstating the everything option even
employing the term "control freaks" to the developers who took the decision to
remove this option in a long thread on the Fedora List. I explained my use of
that term during that debate; my intent was polemical, the intentional use of
hyperbole to excite debate. I hope the developer community has taken a look at
several very long threads that have been generated on this subject, both on the
development list and on Fedora-list. I perfectly understand that I may not
understand all the issues pertaining to this decision, but, I hope that the
developer community also understands that this decision has generated extreme
rancor in your user base, and that it would serve you well to explain it
further. I would also hope that you would find some ways to at least partially
accomodate the users that would like to see this option reinstated. I haven't
tried the right-click option above described - perhaps this will be sufficient,
but I hope that one of you can find a venue to further explain this decision in
terms that the non-developer community can understand as it has angered many
among your most dedicated end-users. I currently actively administer six
different distros on various machines - Fedora is my favorite. My comments were
intended to be criticizing, not condemning, and I hope they are taken in that
spirit. I have not made the effort to intervene in any of the other distros I
use because the other flaws in them overshadow what I see as Fedora's greatest
advantage - it's freedom of action and configurability combined with its cutting
edge rapid adoption of improvements to Linux as an OS. So, I'm critical of this
decision, but, with a spirit of hoping that Fedora retains the fundamental
characteristics that make it the best distro available. 
Comment 5 Dan Thurman 2006-03-11 11:59:28 EST
TO WHOM THIS CONCERNS,

I like the 'install everything' button, only because it enables ALL items
on the list and once selected, I can then go back and individually deselect
the items I do not want.  I want in almost all case, most everything except
those items I do not want which are FAR few compared to the items I do want.

That said, I wanted to point out that your selection interface should be
more of giving the installer ALL the tools to make it as painless as possible
to install packages.

Here are a few suggestions, although it comes from my experiences from other
vendors that I find useful:

1) Select all packages in the list
2) Deselect all packages in the list
3) Select individual items in the list
4) Deselect individual items in the list
5) Select group(s) in the list
6) Deselect group(s) in the list
7) Allow user to define package source location(s)
   a) Source is CD/DVD
   b) Source is local directory(s)
   c) Source is URL
   d) Source is combination a,b,c of any order (allows for
      choices based on fastest download of packages - and
      if done in a,b,c order makes it possible to reduce
      load on download mirrors.
8) Allow user to define a template/macro/script to automate the installation 
process
   a) It may be possible to use the source location of the template,
      macro, script list as defined in 7a-7d so that the installer
      can install from a standard template - so that you can define
      a HIGH SECURITY template, a DEVELOPER template, or TYPICAL or
      any kind or type of installation methods that suits his/her needs.

Note: If a GUI is provided for package installation, you might want to
      consider using the SHIFT/CONTROL arrow/mouse key/button to aid
      in the selection and deselection of lists.  Clicking a checkbox
      IMHO is a VERY POOR way to select packages because it takes too
      darn long and adds to carpal tunnel syndrome by overuse of your
      index (or pinky) finger. :-)

The KEY here, is give the installer some highly useful tools to make
their job as easy and painless as possible.  If there is more things
to add to my above suggested list, then by all means use it but please
make sure that it makes sense!!  You cannot control or prevent users
from making the 'right or sensible' choice, but then that is up to
the installer, right?
Comment 6 Ronald Cole 2006-04-17 23:37:13 EDT
(In reply to comment #1)
> Everything starts to have far less concrete meanings as we move towards
> supporting multiple repositories which could well have conflicting packages. 
> Already 50% of people think everything should exclude language support packages
> and another 50% think that it shouldn't.  

Yeah, and the Red Hat installer used to not differentiate between the language
of the locale and the language of the OS installer.  So, it's a real no-brainer
to figure out that you need to have an "Everything" option that pays attention
to the languages you told the installer to install, and an "Absolutely
Everything" that installs absolutely everything.
 
> Also, when the UI is displaying groups of packages (where each package is
> explicitly listed), having a group which is magic is difficult so support and
> also just doesn't fit in the the interface.

Obviously, all imaginable groups are going to be subsets of "Absolutely
Everything".  I can't fathom what it is about that that you see as being so
"magical".

> The everything install as an interactive option is not coming back.

Great.  I guess that means that it won't be in RHEL5.  At least not tested and
fixed if it's broken.  So, why force your paying customers have to deal with
possible broken packages in your distributions?

Anyway, I can install everything in Fedora from the DVD with four lines of code.
 I've attached my script for the edification and enlightenment of your yum
maintainer and all the FC5 "Install Everything" users you've inconvenienced.  I
use it after a default install of FC5.  (why default?  because checking to
include "Software Development" and "Web Server" crashes the FC5 x86_64
installer!  but that's another bug for another day...)
Comment 7 Ronald Cole 2006-04-17 23:41:42 EDT
Created attachment 127903 [details]
bash script to "install everything"

See comment #6 for a short discussion about this script.
Comment 8 JC 2006-05-17 15:31:16 EDT
I just can't believe the latest and greatest version of fedora has taken the
"end-user is a moron, let's make all the decisions for them" approach. It isn't
hard to have an "Install Everything" option that would include everything
published at the time that the "stock" kernel comes out. "Install Everything"
does not mean "everything up to this day".

The omission of "Install Everything" and "Minimal Install" were terrible
decisions and I agree with the first poster that this is an act of sabotage.

Note You need to log in before you can comment on or make changes to this bug.