Bug 183873 - beagle user has same uid as nut user
Summary: beagle user has same uid as nut user
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: beagle   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2006-03-03 10:34 UTC by Nils Philippsen
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-03 17:23:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nils Philippsen 2006-03-03 10:34:28 UTC
Description of problem:

SSIA, both beagle's as nut's preinstall scripts use UID/GID 57 to install their
respective users. One of these users won't get created as the UID/GID is
duplicate. This leaves either beagle's or nut's files owned by root instead of
the real user/group.

Version-Release number of selected component (if applicable):

beagle-0.2.1-15
nut{,-client,-cgi}-2.0.2-6.2

How reproducible:
Easy

Steps to Reproduce:
1. Try to install both beagle and one of the nut packages
  
Actual results:
  Installing: nut-client                                       [
163/1321]warning: group nut does not exist - using root
  Installing: nut-client                   #                   [
163/1321]warning: group nut does not exist - using root
  Installing: nut-client                   ##################  [
163/1321]warning: user nut does not exist - using root
warning: group nut does not exist - using root
  Installing: nut-client                   ##################  [
163/1321]warning: user nut does not exist - using root
warning: group nut does not exist - using root

Expected results:
No warnings, both users/groups existent with different UIDs/GIDs.


Additional info:
I filed this against beagle because nut has been there for a long time and
users' systems may already have a nut user/group with that uid/gid. IMO, this
should definitely be fixed before FC5 goes GA.

Comment 1 Alexander Larsson 2006-03-03 11:12:33 UTC
Fixed in 0.2.1-17


Note You need to log in before you can comment on or make changes to this bug.