This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 183878 - Missing disk space indication / Failure due to insufficient disk space.
Missing disk space indication / Failure due to insufficient disk space.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-03-03 06:05 EST by Gilboa Davara
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-03 16:07:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gilboa Davara 2006-03-03 06:05:32 EST
Description of problem:
A. During the initial package selection, Anaconda doesn't offer any indication
how much disk-space is required, used or available.
B. Anaconda package selections do not warn the user, if there's insufficient
disk space for the selected packages.
C. During the installation process itself, Anaconda doesn't show any indication
on how much disk space is being used / left / etc.
D. Once the disk space runs out, Anaconda installation fails, with no meaningful
warning and the machine reboots. (with no indication as to the source of the
problem.)

Version-Release number of selected component (if applicable):
FC5T3.

How reproducible:
Always.

Steps to Reproduce:
1. Boot from FC5T3 CD.
2.
3.
  
Actual results:
See above.


Expected results:
Anaconda should display the actual disk space, total remaining space and total
size of selected packages.
If a user selects too many packages, above the free disk space, Anaconda should
display an warning message, before the actual installation takes place. 
If the installation fails due to insufficient disk space, Anaconda should
display a meaningful error code. If possible, Anaconda should allow recovery,
starting over from the initial setup stage.

Additional info:
N/A.
Comment 1 Chitlesh GOORAH 2006-03-03 06:39:35 EST
It would be useful too for Kadischi to have a "total size of selected packages"
indicator. Hence we can then differentiate from build a live CD or a DVD
Comment 2 Jeremy Katz 2006-03-03 11:07:50 EST
We should be warning if there's not sufficient disk space to do the install. 
Given that we don't resolve dependencies on the fly (it would be slow), we can't
really give good disk space indications in the package selection screen.  But we
should definitely tell you there's not enough prior to actually starting to put
packages on the disk.

Chris -- can you try this?
Comment 3 Chris Lumens 2006-03-03 16:07:14 EST
We now have an error window that pops up after package selection telling you if
you don't have enough space.  You can also go back and adjust your selections
and try again.

Note You need to log in before you can comment on or make changes to this bug.