Bug 1838934 - `oc new-app` will rollout twice when deployment created at the first time
Summary: `oc new-app` will rollout twice when deployment created at the first time
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-controller-manager
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Michal Fojtik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-22 05:59 UTC by zhou ying
Modified: 2020-07-13 17:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:41:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oc pull 437 0 None open Bug 1838934: Fix new-app producing deployment that trigger twice after creation 2020-06-24 03:14:24 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:41:18 UTC

Description zhou ying 2020-05-22 05:59:50 UTC
Description of problem:
`oc new-app` will rollout twice when deployment created at the first time

Version-Release number of selected component (if applicable):
[root@dhcp-140-138 ~]# oc version 
Client Version: 4.5.0-202005201357-24c1ae6
Server Version: 4.5.0-0.nightly-2020-05-21-135919
Kubernetes Version: v1.18.2

How reproducible:
always

Steps to Reproduce:
1) `oc new-app openshift/hello-openshift`
2) `oc status`
Actual results:
2) Will show deployment has rollout tiwce.
[root@dhcp-140-138 ~]# oc status
svc/hello-openshift - 172.30.99.251 ports 8080, 8888
  deployment/hello-openshift deploys istag/hello-openshift:latest 
    deployment #2 running for 23 minutes - 1 pod
    deployment #1 deployed 23 minutes ago
[root@dhcp-140-138 ~]# oc get rs
NAME                         DESIRED   CURRENT   READY   AGE
hello-openshift-6bb694df8b   1         1         1       42s
hello-openshift-857f8d6b7d   0         0         0       43s

Expected results:
2. Only rollout one time.

Additional info:

Comment 3 zhou ying 2020-05-27 03:09:33 UTC
[root@dhcp-140-138 ~]# oc create deployment mydd --image=openshift/hello-openshift
deployment.apps/mydd created
[root@dhcp-140-138 ~]# oc get rs
NAME              DESIRED   CURRENT   READY   AGE
mydd-5c8d976bcd   1         1         1       14s
[root@dhcp-140-138 ~]# oc rollout history deploy/mydd
deployment.apps/mydd 
REVISION  CHANGE-CAUSE
1         <none>

[root@dhcp-140-138 ~]# oc get po 
NAME                    READY   STATUS    RESTARTS   AGE
mydd-5c8d976bcd-jr5jn   1/1     Running   0          46s
[root@dhcp-140-138 ~]# oc version 
Client Version: 4.5.0-202005270117-384535d
Server Version: 4.5.0-0.nightly-2020-05-26-224432
Kubernetes Version: v1.18.2+9835af5

Comment 4 errata-xmlrpc 2020-07-13 17:41:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.