Bug 1838960 - Cannot change virtualHostedStyle to false for configs.imageregistry
Summary: Cannot change virtualHostedStyle to false for configs.imageregistry
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Oleg Bulatov
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-22 07:31 UTC by Wenjing Zheng
Modified: 2020-07-13 17:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:41:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-image-registry-operator pull 562 0 None open Bug 1838960: Change region parameters only when region is not configured 2020-06-24 03:14:27 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:41:18 UTC

Description Wenjing Zheng 2020-05-22 07:31:35 UTC
Description of problem:
Cannot change virtualHostedStyle to false for configs.imageregistry:
  storage:
    s3:
      bucket: wzheng45-54qvz-image-registry-us-east-2-ugbxlbxflxsujkhunnkiqn
      encrypt: true
      region: us-east-2
      virtualHostedStyle: true

Log from image registry operator log:
I0522 07:24:20.882866      14 clusteroperator.go:91] event from workqueue successfully processed
I0522 07:24:22.034727      14 controller.go:279] object changed: *v1.Config, Name=cluster (metadata=false, spec=true): changed:spec.storage.s3.virtualHostedStyle={"false" -> "true"}, changed:status.conditions.0.lastTransitionTime={"2020-05-21T23:23:16Z" -> "2020-05-22T07:24:20Z"}, added:status.conditions.0.message="User supplied S3 bucket exists and is accessible"
I0522 07:24:22.046608      14 clusteroperator.go:91] event from workqueue successfully processed
I0522 07:24:22.046700      14 controllerimagepruner.go:309] event from image pruner workqueue successfully processed
I0522 07:24:22.048155      14 controller.go:303] object changed: *v1.Config, Name=cluster (status=true): changed:metadata.resourceVersion={"182481" -> "182499"}, changed:spec.storage.s3.virtualHostedStyle={"false" -> "true"}, changed:status.conditions.0.lastTransitionTime={"2020-05-21T23:23:16Z" -> "2020-05-22T07:24:20Z"}, added:status.conditions.0.message="User supplied S3 bucket exists and is accessible", changed:status.observedGeneration={"2.000000" -> "3.000000"}
I0522 07:24:22.058026      14 controller.go:345] event from workqueue successfully processed


Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-21-135919

How reproducible:
Always

Steps to Reproduce:
1.Change virtualHostedStyle to false in configs.imageregistry
2.
3.

Actual results:
Check the config is still true.

Expected results:
It should change to false.

Additional info:

Comment 3 Wenjing Zheng 2020-05-27 02:40:46 UTC
Verified on  4.5.0-0.nightly-2020-05-26-224432.

Comment 4 errata-xmlrpc 2020-07-13 17:41:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.