Bug 1838997 - Kuryr CI failing with pep8 issues
Summary: Kuryr CI failing with pep8 issues
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Michał Dulko
QA Contact: GenadiC
URL:
Whiteboard:
Depends On:
Blocks: 1847105
TreeView+ depends on / blocked
 
Reported: 2020-05-22 10:02 UTC by Maysa Macedo
Modified: 2020-07-13 17:41 UTC (History)
0 users

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1847105 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:41:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kuryr-kubernetes pull 241 0 None closed Bug 1838997: Fix hacking min version to 3.0.1 2020-06-24 03:14:38 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:41:27 UTC

Description Maysa Macedo 2020-05-22 10:02:33 UTC
Description of problem:

flake8 new release 3.8.0 added new checks and gate pep8
job start failing. hacking 3.0.1 fix the pinning of flake8 to
avoid bringing in a new version with new checks.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Michał Dulko 2020-05-22 10:05:40 UTC
Note for QE - this is fixing the OKD's PEP8 CI and requires no functional verification.

Comment 4 Maysa Macedo 2020-06-16 07:52:03 UTC
Moving this bug back to ON_QA as requires backport to 4.4.

Comment 5 Maysa Macedo 2020-06-16 08:50:20 UTC
As this is unblocked the CI, I'm moving this to VERIFIED.

Comment 6 errata-xmlrpc 2020-07-13 17:41:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.