Bug 1839041 - VM wizard selects old common template
Summary: VM wizard selects old common template
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Filip Krepinsky
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-22 11:35 UTC by Filip Krepinsky
Modified: 2020-07-13 17:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause &Consequence: Wizard selected wrong/old version of a common template when multiple versions of the same template were present. Fix & Result: VM Wizard selects the newest version and the newest template to create VMs
Clone Of:
Environment:
Last Closed: 2020-07-13 17:41:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5544 0 None closed Bug 1839041: prefer common templates with newer version and timestamp 2020-08-25 14:40:03 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:41:27 UTC

Description Filip Krepinsky 2020-05-22 11:35:55 UTC
Description of problem:
VM wizard selects old version of a common template when multiple versions of the same template are present.


How reproducible:
50, depends on the name of the template



Expected results:
Should select the newest template (order by version and timestamp)

Comment 3 Radim Hrazdil 2020-05-27 12:33:46 UTC
Verified - created 2 common templates with different versions and properties and observed that the properties from newer common-template are used
release-4.5

Comment 4 errata-xmlrpc 2020-07-13 17:41:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.