Bug 1839080 - Pipeline Multistream log shows error message while retrireving logs.
Summary: Pipeline Multistream log shows error message while retrireving logs.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Karthik Jeeyar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-22 12:51 UTC by Karthik Jeeyar
Modified: 2020-07-13 17:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:41:07 UTC
Target Upstream Version:


Attachments (Terms of Use)
pipeilne run error (165.62 KB, image/png)
2020-05-22 12:51 UTC, Karthik Jeeyar
no flags Details
Pipeline Multistream log does not show error message while retrireving logs. (44.88 KB, image/png)
2020-06-01 19:23 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5539 0 None closed Bug 1839080: fix empty Content in coFetchText causes PipelineLogs to show error 2020-06-24 03:18:12 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:41:27 UTC

Description Karthik Jeeyar 2020-05-22 12:51:06 UTC
Created attachment 1691054 [details]
pipeilne run error

Description of problem:

The MultiStreamLog component does not check if it got a string before attempting to use a string method on it... thus causing an error to appear in logs.


Version-Release number of selected component (if applicable):
4.5

How reproducible:
Always

steps to Reproduce:
1. Visit any existing pipelinerun logs page.



Actual results:
At the beginining of the log it shows a message `An error occurred while retreiving the logs`

Expected results:

It should not show the error msg while retrieving the logs.

Comment 3 spathak@redhat.com 2020-06-01 19:23:38 UTC
Created attachment 1694170 [details]
Pipeline Multistream log does not show error message while retrireving logs.

Comment 4 spathak@redhat.com 2020-06-01 19:37:05 UTC
Verified on build version: 4.5.0-0.ci-2020-05-29-203954
Browser version: Firefox 73

Comment 5 errata-xmlrpc 2020-07-13 17:41:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.