Bug 183909 - doesn't play nicely with gnome-mount
doesn't play nicely with gnome-mount
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus-cd-burner (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-03 12:21 EST by Bill Nottingham
Modified: 2014-03-16 22:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-03 22:56:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-03-03 12:21:48 EST
Description of problem:

If gnome-mount mounts a data CD, n-c-b fails to unmount it.


Version-Release number of selected component (if applicable):

nautilus-cd-burner-2.13.92-1

How reproducible:

Every time.

Steps to Reproduce:
1. Insert a data CD
2. Wait for gnome-mount to mount it
3. Run n-c-b --source-iso=whatever. Or I suppose you could actually use the UI.
  
Actual results:

** (nautilus-cd-burner:18623): WARNING **: Couldn't unmount volume in drive:
/dev/hdc

and burn fails.

Additional info:

Looking at strace -f of n-c-b, I see:

18625 execve("/bin/umount", ["/bin/umount", "/dev/hdc"], [/* 1 var */]) = 0

Shouldn't that be gnome-umount --device=/dev/hdc?
Comment 1 David Zeuthen 2006-03-03 12:27:44 EST
Ideally n-c-b would use gnomevfs.. until that happens let's just patch this in
the RPM
Comment 2 Matthias Clasen 2006-03-03 18:19:49 EST
David, you mean patching n-c-b to use gnome-umount --device=/dev/hdc ?
Comment 3 David Zeuthen 2006-03-03 19:00:05 EST
Matthias, yea.. that would work. Ideally send this upstream too, but would
require a bit more work..
Comment 4 Matthias Clasen 2006-03-03 22:50:57 EST
Hmm, gnome-mount code was already there. I have rebuilt the package with
gnome-mount BuildReq and Req, and the unmounting seems to work for me now.
Of course, burning cds still fails due to cdrecord :-(

Note You need to log in before you can comment on or make changes to this bug.