Bug 183915 - Possible LGPL violation with dovecot
Possible LGPL violation with dovecot
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dovecot (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-03 13:12 EST by Daniel Qarras
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 10:08:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Qarras 2006-03-03 13:12:46 EST
Description of problem:

Dovecot is an IMAP/POP server mostly licensed under the LGPL 2.1. LGPL 2.1
section 2 says:

"a)  The modified work must itself be a software library."

See http://www.gnu.org/copyleft/lesser.html for full license text.

Red Hat SRPM contains patches that modify dovecot but the "modified work" is
still a server, not "a software library". So it seems that at least in theory
here might be a violation of LGPL.

Additional info:

dovecot was just one of many candidates that are licensed under the LGPL,
modified, and not distributed as "a software library". If we read the LGPL
literally, this might be a problem. But I hope you prove me being wrong. If not,
then I don't know what to do with all those non-library RPMs distributed under
LGPL today.
Comment 1 Petr Rockai 2006-03-06 05:57:23 EST
I'll go and check if dovecot links with anything GPL-incompatible. If no, we 
can easily opt for plain GPL so this becomes a non-issue. If not, i'll see how 
is 2a) to be interpreted in context of non-libraries. *Goes investigating*. 
Comment 2 Daniel Qarras 2006-05-29 04:54:48 EDT
Any news with this?
Comment 3 Daniel Qarras 2006-09-20 16:17:36 EDT
So, any news with this now?
Comment 4 Petr Rockai 2006-10-04 10:08:39 EDT
The issue is moot, since we link against mysql client libs which are GPL which 
means we have to use GPL anyway. Although i believe that modifying LGPL 
program and distributing again under LGPL is legal, I am not a lawyer so i 
can't help you much on that.

Note You need to log in before you can comment on or make changes to this bug.