Bug 1839233 - command line terminal pods never scale to 0
Summary: command line terminal pods never scale to 0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: cvogt
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-22 19:45 UTC by cvogt
Modified: 2020-07-13 17:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:41:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
command line terminal pods scale to 0 (65.81 KB, image/png)
2020-06-03 22:51 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5546 0 None closed Bug 1839233: send activity tick to keep the cloud shell terminal alive 2020-06-24 03:18:22 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:41:39 UTC

Description cvogt 2020-05-22 19:45:20 UTC
Description of problem:
Cloudshell pod never scales to zero. Therefore indefinitely consuming resources per user per terminal.

Prerequisites (if any, like setup, operators/versions):
Install the che-workspace-controller

Steps to Reproduce:
1. Open the OpenShift command line terminal
2. Wait as long as you want to and observe the pod that was created in the namespace where the workspace was created

Actual results:
Pod will be always be present.

Expected results:
After a certain amount of time (TBD) the pod should scale to 0.

Reproducibility (Always/Intermittent/Only Once):
always

Build Details:
4.5.0-0.ci-2020-05-18-204038

Additional info:
Requires https://github.com/openshift/console/pull/5332 to merge.
This PR adds support for the endpoint `/api/terminal/$namespace/$workspaceName/activity/tick`
All we need to do is POST a request to this endpoint every X seconds while the user is active in the terminal.
Suggestion: track how long it's been since the last POST request was sent. If activity occurs later than 1 minute since, then send another POST request.

Comment 3 spathak@redhat.com 2020-06-03 22:51:05 UTC
Created attachment 1694908 [details]
command line terminal pods scale to 0

Comment 4 spathak@redhat.com 2020-06-03 22:51:35 UTC
Verified on build version: 4.5.0-0.nightly-2020-06-03-105031
Browser version: firefox 73

Comment 5 errata-xmlrpc 2020-07-13 17:41:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.