Bug 1839285 - "ResourceRequirement" widget - can't enter inputs for Couchbase Operator but works for ArgoCD Operaror
Summary: "ResourceRequirement" widget - can't enter inputs for Couchbase Operator but ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-23 00:48 UTC by tony.wu
Modified: 2020-07-13 17:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Manifested, discovered, and fixed before release.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:41:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
1__NG_[couchbaseCluster]_creation_form.png (924.14 KB, image/png)
2020-05-23 00:48 UTC, tony.wu
no flags Details
2__OK_[ArgoCD]_creation_form.png (680.09 KB, image/png)
2020-05-23 00:48 UTC, tony.wu
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5567 0 None closed Bug 1839285: Add default values for object type operand form fields 2021-02-01 05:42:43 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:41:39 UTC

Description tony.wu 2020-05-23 00:48:40 UTC
Created attachment 1691206 [details]
1__NG_[couchbaseCluster]_creation_form.png

Description of problem:
When creating "CouchbaseCluster" with the form view (Couchbase Operator), the "ResourceRequirement" widget doesn't allow me to enter any inputs (digit nor char). However the same widget works fine for creating "ArgoCD" instance (ArgoCD Operator).

See more details in the attached screenshots.

Version-Release number of selected component (if applicable):
OCP4.5

How reproducible:
100%

Steps to Reproduce:
1.  Install "Couchbase Operator" from `OperatorHub` view
2. Create "CouchbaseCluster" from `Installed Operartors` view
3. Expand "Servers" --> "Pods" section on the form, and enter inputs in "Resource Requirements" widget

Actual results:
Can't enter inputs

Expected results:
Allow entering inputs

Additional info:

Comment 1 tony.wu 2020-05-23 00:48:56 UTC
Created attachment 1691207 [details]
2__OK_[ArgoCD]_creation_form.png

Comment 4 shahan 2020-05-27 10:53:02 UTC
1.  Install "Couchbase Operator" from `OperatorHub` view
2. Create "CouchbaseCluster" from `Installed Operartors` view
3. Expand "Servers" --> "Pods" section on the form, and enter inputs in "Resource Requirements" widget
Now can input value in widget
4.5.0-0.ci-2020-05-27-081937

Comment 5 errata-xmlrpc 2020-07-13 17:41:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.