Bug 1839460 - [v2v][RFE] RHV to CNV single VM Import: There is no Cancel button/api option
Summary: [v2v][RFE] RHV to CNV single VM Import: There is no Cancel button/api option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Filip Krepinsky
QA Contact: Nandini Chandra
URL:
Whiteboard:
Depends On:
Blocks: 1848402
TreeView+ depends on / blocked
 
Reported: 2020-05-24 08:16 UTC by Ilanit Stein
Modified: 2020-10-27 16:00 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1848402 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:00:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5693 0 None closed Bug 1839460: fix VMImport cancelation options 2020-10-04 00:15:22 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:00:54 UTC

Description Ilanit Stein 2020-05-24 08:16:31 UTC
Description of problem:
On current RHV to CNV import VM single VM implementation, there is no "Cancel"
button in the UI, or a cancel option in the api.

Currently, to cancel a VM import 
In api - Delete the Import CR.
In UI - Delete the VM - that will delete the conversion pod, and PVC, but not the PV.

Adding a Cancel button will improve the usability.

Version-Release number of selected component (if applicable):
CNV-2.4

Comment 1 Filip Krepinsky 2020-05-25 12:55:44 UTC
We could update the text to "Cancel" instead of "Delete", but I am not sure we should be managing user PVs. Also because we are not doing that anywhere else, so it might be an unexpected behavior. This could also damage some storage classes.

Comment 6 Nandini Chandra 2020-10-07 23:07:06 UTC
Verified in 4.6.0-fc.8

Comment 8 errata-xmlrpc 2020-10-27 16:00:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.