Bug 183958 - Mono-beagled leaks memory
Mono-beagled leaks memory
Status: CLOSED DUPLICATE of bug 183898
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-03 21:19 EST by Ivan Gyurdiev
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-08 09:17:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2006-03-03 21:19:38 EST
After 3-4 days of usage the resource monitor applet reports:

Mono-beagled: 
169.3 MiB resident memory
205.6 MiB writable memory
16.9 MiB shared memory

Mono-beagled-helper:
65.2 MiB resident memory
73.4 MiB writable memory
13.5 MiB shared memory

... and this keeps increasing...
I find it highly unusual that my normal gnome desktop uses 700 MB RAM.

=============

Also, occasionally I see 20% cpu usage by beagle, usually at the most
inconvenient time, as others have reported on fedora-list.



=========
Comment 1 Ivan Gyurdiev 2006-03-06 07:19:45 EST
Hmm, this situation might have been improved recently [ I see lower memory usage
right now ]. I need to do more testing to be sure there is a leak involved...

Leak or not, mono-beagled has completely unreasonable resource requirements,
especially for software I don't use [ I'm sure it's great, but I know exactly
where each and every thing is on my desktop ]. Right now it's using 90% CPU, and
about 180MB resident memory [ 2 daemons + beagleindex ].






Comment 2 Jonathan Berry 2006-03-07 00:37:07 EST
I just encountered this apparent memory leak.  After less than a couple of
hours, mono-beagled is using 71.4 % of my 2.0 GB of RAM.  That's 1.4 GB.  This
does not seem to be good behavior to me.  Oh, and I just noticed that my 2.0 GB
of swap is also being heavily used.  Normally, swap is not touched.

$ free
             total       used       free     shared    buffers     cached
Mem:       2056132    2018152      37980          0       8772     196748
-/+ buffers/cache:    1812632     243500
Swap:      2096472    1343796     752676

$ ps aux | grep mono-beagled
berryja   2946  0.2  0.6 178592 12780 ?        Sl   21:36   0:21
mono-beagled-helper --debug /usr/lib64/beagle/IndexHelper.exe
berryja   2723  0.6 70.7 2963828 1453764 ?     Sl   21:34   0:47 mono-beagled
--debug /usr/lib64/beagle/BeagleDaemon.exe --bg
Comment 3 Rahul Sundaram 2006-03-08 09:17:52 EST

*** This bug has been marked as a duplicate of 183898 ***
Comment 4 Jonathan Berry 2006-03-08 09:27:24 EST
Rahul,
While bug 183898 is similar to this one, it does not mention memory usage, only
CPU usage.  Is this really a duplicate?  Should we update 183898 to include the
memory usage problems and just track it all in one bug?
Jonathan
Comment 5 Rahul Sundaram 2006-03-08 09:39:32 EST
(In reply to comment #4)
> Rahul,
> While bug 183898 is similar to this one, it does not mention memory usage, only
> CPU usage.  Is this really a duplicate?  Should we update 183898 to include the
> memory usage problems and just track it all in one bug?
> Jonathan

These are duplicating since there are essentially the same problem of a
potential memory leak. Updating the open bug report can help but a duplicate is
always cross referenced to help the relevant developers dig out specific
information to help reproduce issues

Note You need to log in before you can comment on or make changes to this bug.