Bug 183968 - media check seems to check more than the info which is on the cd image => this causes probably unwanted effects if the cd is burned with other options
media check seems to check more than the info which is on the cd image => thi...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-04 03:38 EST by Juergen Bullinger
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-04 11:12:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juergen Bullinger 2006-03-04 03:38:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; de-DE; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Hi, I don't know if this is related to anaconda. Please forward the message if it is wrong.

The message is not really related to x86_64 and also not really to FC5. It seems to be a general problem, because I already had it with FC4.

I downloaded the CD images and did a sha1sum and compared them to the ones on your site. They are correct.

I burnt the cd images on cds using cdrecord with the following command (it is in a script $1 is the image name)

su --command="cdrecord -v speed=4 -tao $1"

unfortunately cdrecord reports that dao is not supported by my burner which is most likely just false alarm.


it seemed to work fine. My burner is a IDE-DVD-Burner which of course can handle more than 4x-speed.

Everything worked fine, but the selfcheck which can be executed (check media) when you boot from the cds fails for all of the burned cds. When this happened the first time (it was still FC4) I thought the cds might be corrupt and burned them again. But it was the same. Then I tried to install from this cds anyway and they worked.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. download Fedora core images (e.g. FC5.3, but it should also happen with FC4)
2. burn these images using the command above
3. do a media check after boot from the cd
  

Actual Results:  it seems that the "check media" operation also checks other parts of the cd, which are not contained in the image file. In my opinion this should not happen. If it is necessary to also check this parts of the cd, they should be checked separately so that a message like this can be displayed:

"the cd contents seems to be ok, but the lead in/lead out differs. This might be caused by different options for burning the cd... If you are unsure, please try to burn your cd again with the following options/speed...."

or something like this

Additional info:
Comment 1 Jeremy Katz 2006-03-04 11:12:15 EST
It's actually just checking the contents of the data region.  If it's failing,
then that means that the md5sum of the data isn't matching what it's expected to
be.  It could be that your drive does retries differently with the usage pattern
of installing packages or you don't hit the package which is bad while
installing but there are inconsistencies within the media which could cause
problems.

Note You need to log in before you can comment on or make changes to this bug.