Bug 183974 - if anaconda can't find a rpm on a http install you must reboot
if anaconda can't find a rpm on a http install you must reboot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
: FutureFeature
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-03-04 07:03 EST by Stefan Geuns
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-25 12:48:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stefan Geuns 2006-03-04 07:03:33 EST
Description of problem:  
I made my own copy of the fedora core 5 test 3 repository, so I can do a local  
http install. But because fedora is ~3GB I didn't download everything. I  
forgot to download some needed files so anaconda couldn't find them. Now I got  
to see the dialog for file not found and my only option was to reboot. Kind of  
annoying, because I didn't have any boot media anymore (booted with grub).  
I want a Retry button in the dialog, so I can download files to my local copy  
and then retry to find it in anaconda. Or an option to select another mirror.  
  
Version-Release number of selected component (if applicable):  
  
  
How reproducible:  
always 
  
Steps to Reproduce:  
1. Download a fedora core repo, but exclude some needed rpms 
2. install fedora  
3.  
    
Actual results:  
forced to reboot  
  
Expected results:  
retry option or other mirror selection dialog 
  
Additional info:
Comment 1 Jeremy Katz 2006-03-04 11:12:58 EST
At this point, we probably can't adjust this for FC5, but putting on a list to
ensure that we do for FC6
Comment 2 Stefan Geuns 2006-03-05 11:01:22 EST
I'm happy too if you can redo the entire checks (and formatting?).  
Comment 3 Chris Lumens 2006-05-25 12:48:02 EDT
This should be much better in Rawhide.  Please test against FC6test1 when it is
release and let us know if it's still mishebaving.
Comment 4 Stefan Geuns 2006-07-13 09:01:34 EDT
I finally got the chance to test it and it looks really good except for 1 
small bug. (FC6 test 1)
I have to click Retry twice before anaconda finds the package.

Many thanks for the fix, it saved me much time!

Note You need to log in before you can comment on or make changes to this bug.