Bug 1839746 (OCPRHV-79-4.5) - OCPRHV-79: User cannot fix wrong oVirt user once provided to the installer
Summary: OCPRHV-79: User cannot fix wrong oVirt user once provided to the installer
Keywords:
Status: CLOSED ERRATA
Alias: OCPRHV-79-4.5
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.6.0
Assignee: Douglas Schilling Landgraf
QA Contact: Jan Zmeskal
URL: https://issues.redhat.com/browse/OCPR...
Whiteboard:
Depends On: OCPRHV-176 1850723
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-25 12:22 UTC by Jan Zmeskal
Modified: 2020-10-27 16:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:01:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 3663 0 None closed BUG 1839896: ovirt: General Improvements 2020-10-22 06:46:09 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:01:27 UTC

Description Jan Zmeskal 2020-05-25 12:22:56 UTC
Description of problem:
When you provide a wrong oVirt user to openshift-install, the authentication with oVirt (as is to be expected) fails. However, user is prompted only to re-enter their password. And of course, even if they provide the correct password, authentication will fail again. Therefore their only option is to kill the installer and start again, which is not great UX.

Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

How reproducible:
100 %

Steps to Reproduce:
https://pastebin.com/xdDWCMuB

Actual results:
Installer does not provide a change to input oVirt user again

Expected results:
When authentication fails, user should be prompted to enter both username and password again.

Comment 1 Douglas Schilling Landgraf 2020-05-27 10:57:38 UTC
Jan, how about the approach below? If we fail to auth, we show to users the error and exit.

INFO Detected: Engine CA as trusted locally...    
? oVirt engine username admin@internal
? oVirt engine password ********
 Failed to connect to oVirt platform Error during SSO authentication access_denied : Cannot authenticate user 'admin@internal': Unable to log in. Verify your login information or contact the system administrator..
 Exiting....

Comment 2 Jan Zmeskal 2020-05-27 14:35:40 UTC
Hi Douglas, in ideal world I'd rather see the installer prompting for username and password again. But if that proves too difficult to implement, your proposed solution works fine.

Comment 3 Douglas Schilling Landgraf 2020-05-27 17:55:29 UTC
(In reply to Jan Zmeskal from comment #2)
> Hi Douglas, in ideal world I'd rather see the installer prompting for
> username and password again. But if that proves too difficult to implement,
> your proposed solution works fine.

Let's try the hard way ;-)

Comment 7 Jan Zmeskal 2020-06-19 08:49:33 UTC
Hi Douglas, I basically verified this during verification of different BZ. Please see the comment here: https://bugzilla.redhat.com/show_bug.cgi?id=1814373#c19

I like the user experience much more now. The only thing I'm missing is that user does not know that they should press Ctrl+C to be able to provide username again. All they get is this:

Sorry, your reply was invalid: failed to connect to Engine platform Error during SSO authentication access_denied : Cannot authenticate user 'homer@N/A': No valid profile found in credentials..

Could we also inform them in this message that they can re-enter the username by pressing Ctrl+C?

Comment 8 Jan Zmeskal 2020-06-19 12:28:49 UTC
After offline agreement with Douglas, the defect described in comment 7 will be treated as a new bug, therefore moving this to VERIFIED.

Comment 9 Jan Zmeskal 2020-06-19 12:47:10 UTC
Issue described in comment 7 is now tracked here: https://bugzilla.redhat.com/show_bug.cgi?id=1848987

Comment 11 errata-xmlrpc 2020-10-27 16:01:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.