Bug 18398 - /etc/pcmcia/network is buggy
Summary: /etc/pcmcia/network is buggy
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: hwdata (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-05 12:32 UTC by lionel.cons
Modified: 2014-03-17 02:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 23:00:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description lionel.cons 2000-10-05 12:32:08 UTC
This defect is present since 6.1 at least. The parameter ONBOOT that can be
set in /etc/sysconfig/network-scripts/ifcfg-eth0 is ignored for PCMCIA
network cards. This is because the initialisation is done via the
/etc/pcmcia/network script which does not differentiate a normal boot
(where ONBOOT should be obeyed) from an other event (like card insertion).

We use a here a quick hack to make it work, maybe you'll have a better
solution...

--- /etc/pcmcia/network.old Mon Sep 27 16:13:35 1999
+++ /etc/pcmcia/network Fri Sep 15 11:14:23 2000
@@ -13,7 +13,8 @@
 
 case "${action:?}" in
 'start')
-       /etc/sysconfig/network-scripts/ifup ifcfg-${device}
+       /sbin/pidof -x /etc/rc.d/rc >/dev/null 2>&1 && extra=boot
+       /etc/sysconfig/network-scripts/ifup ifcfg-${device} $extra
     ;;
 'stop')
        /etc/sysconfig/network-scripts/ifdown ifcfg-${device}

Comment 1 keithu@parl.clemson.edu 2000-10-06 17:59:37 UTC
I'm glad you submitted that bug.  That one REALLY annoys me as I move from
dial-up to office frequently and it means that I have to stop eth0 when I boot
at home.  I had never bothered to track it down though...

Comment 2 Bill Nottingham 2003-06-05 23:00:47 UTC
Currently you can set 'ONHOTPLUG=no' for pluggable interfaces.


Note You need to log in before you can comment on or make changes to this bug.