Bug 183982 - unsolvable chain of dependencies
unsolvable chain of dependencies
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Beth Nackashi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-04 09:41 EST by Landon Kelsey
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-05 11:21:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Landon Kelsey 2006-03-04 09:41:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Description of problem:
 up2date dead end package dependency problem
message :
There was a package dependency problem
unsolvable chain of dependencies
GFS-kernel 2.6.11.8-20050601.152643.FC4 requires /lib/modules/2.6.15-1.1831_FC4
cman-kernel 2.6.11.5-20050601.152643.FC4 requires /lib/modules/2.6.15-1.1831_FC4
dlm-kernel 2.6.11.5-20050601.152643.FC4 requires /lib/modules/2.6.15-1.1831_FC4
gnbd-kernel 2.6.11.2-20050601.133124.FC requires /lib/modules/2.6.15-1.1831_FC4

I resolved one similar problem by downloading a package.

I cannot find the /lib/modules/2.6.15-1.1831_FC4 in

http://download.fedora.redhat.com/pu...updates/4/i386

up2date ran great after installing FC4

ALSO! up2date is telling me that I had set up certaing items to be excluded from automatic update and I never did that.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.do a simple FC4 up2date...I have only done straightforward up2date operations
2.
3.
  

Actual Results:  see description

Expected Results:  no dependency problems!

I could not find /lib/modules/2.6.15-1.1831_FC4 to solve problem

Additional info:
Comment 1 John Thacker 2006-10-29 15:21:23 EST
up2date was replaced by pirut and put (package pirut) as of FC5.  Only FC5 and
FC6 are currently fully supported; FC3 and FC4 are supported for security fixes
only.  If this bug occurs in FC3 or FC4 and is a security bug, please change the
product to Fedora Extras and the version to match.  If you can verify that the
bug exists in RHEL as well, please change the product and version appropriately.

The codebase for pirut and pup is quite different, but if a similar bug exists
in pirut and pup in FC5 or FC6, please change the product to pirut and the
version appropriately and update the bug report.

We apologize that the bug was not fixed before now.  The status will be changed
to NEEDINFO, and if the bug is not updated with evidence that it is a security
bug or a bug that affects RHEL, it will be closed.
Comment 2 John Thacker 2006-11-05 11:21:57 EST
Closing per previous message.

Note You need to log in before you can comment on or make changes to this bug.