Bug 183987 - Couldn't update FC4 from FC5 Test3, anaconda ran out of disk space.
Couldn't update FC4 from FC5 Test3, anaconda ran out of disk space.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
: 183989 (view as bug list)
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2006-03-04 11:42 EST by Olen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-20 13:32:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Olen 2006-03-04 11:42:18 EST
Description of problem:
Attempting to update FC4 box (box specs 512 Mb of RAM, 919M of Swap, 180Gb 
disk) from a DVD.
Everything was proceding normal, the previous installaton of FC4 was found and 
selected to be updated.  While preparing the transaction, after a few minutes 
a window appeared and claimed it failed due to being out of disk space. There 
are more than 150Gb free on the physical disk as reported by df -h.  If its a 
disk its referring to, it must be a ram disk.  The physical disk was unchanged 
after this, so FC4 still works.   The popup also said it should let the user 
go back and try again, but I guess that feature hadn't been implemented,so the 
install just exited.

If 512Mb of ram isn't enought to run anaconda/yum for fc5, then I guess this 
isn't a bug.  But I don't know how I'll get updated if thats the case.
I will say that I have a bunch of software installed.  Both Gnome, and KDE, 
and Open Office and much more using yum.

Version-Release number of selected component (if applicable):

FC5 test 3
How reproducible:
I didn't try to reproduce.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Upgrade failed due to out of disk space updating computer with modest amount 
of ram by todays standards, and lots of fc4 packages installed on it.

Expected results:
Ugrade to succeed. 
Additional info:
 Maybe yum should do smaller transactions by groups, such as base first, then 
X11...,  my impression was it tried the whole thing as one huge transaction.  
I guess I can make a local repo out of my DVD, and then do an iterative update 
of the packages for myself.
Comment 1 Chris Lumens 2006-03-04 13:19:18 EST
*** Bug 183989 has been marked as a duplicate of this bug. ***
Comment 2 Olen 2006-03-04 13:37:02 EST
I forgot to mention in the bug report, that the FC4 has had software installed 
from other repositories as well.  Maybe something is installed that would keep 
the FC5 update from happening?

BTW sorry I made a duplicate, the bugzilla page said it failed due to invalid 
product name and asked me to go back. Maybe bugzilla has a bug to.

Olen
Comment 3 Jeremy Katz 2006-03-06 12:00:11 EST
You're probably getting a file conflict.  If you look on tty3, you'll probably
see what exactly is conflicting.  We really should be handling this better :-/
Comment 4 Olen 2006-03-07 09:08:36 EST
Yes, looking on tty3 there was a conflict.  Somehow the i386 version of gnome 
was 2.8.1, but the 64 bit version had been updated.  I'll have to look again 
to even see why the i386 rpms are installed in fc4.  Removing those with yum 
from the fc4 installation, and then doing an update works.

The speed of the update seemed very slow, compared to past installs.  It took 
about 4 hours. I only got to use the finished system a little while this 
morning after I got up.  I will try to read through some bugzilla reports to 
see if some of the things I noticed have been documented here, if not I will 
add them as feed back for the fedora developers.  On the whole, it looks 
pretty nice, seems to be working pretty well.

Comment 5 Paul Nasrat 2006-03-20 13:32:18 EST
This should be fixed in FC5 Final

Note You need to log in before you can comment on or make changes to this bug.