Bug 1839927 - Improve button ID of "Add Network Interface/Add Disk" button
Summary: Improve button ID of "Add Network Interface/Add Disk" button
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.5.0
Assignee: Yaacov Zamir
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-26 03:23 UTC by Guohua Ouyang
Modified: 2020-07-13 17:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:41:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5583 0 None closed Bug 1839927: Improve vm details tabs add buttons 2020-08-06 16:53:48 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:41:45 UTC

Description Guohua Ouyang 2020-05-26 03:23:07 UTC
Description of problem:
Regarding VM network, the button ID is of "Add Network Interface" are:
  - on wizard, it's "#add-nic".
    correct to me.
  - on VM network tab, it's "#create-nic-btn".
    it should align with wizard, like "#add-nic".

Regarding VM Disk, the button ID is of "Add Disk" are:
  - on wizard, it's "#add-disk".
    correct to me.
  - on VM Disk tab, it's "#yaml-create".
    it should align with wizard, like "#add-disk".

It does not affect UI, but breaks automation tests.

Version-Release number of selected component (if applicable):
master

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Radim Hrazdil 2020-05-27 11:53:33 UTC
Verified

Comment 4 errata-xmlrpc 2020-07-13 17:41:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.