This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 183993 - Enabling reverse video mode through the menu (ctrl + middle mousebutton) leaves cursor black together with background being black
Enabling reverse video mode through the menu (ctrl + middle mousebutton) leav...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-04 13:31 EST by Joni Yrjana
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-17 11:54:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joni Yrjana 2006-03-04 13:31:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060202 Fedora/1.0.7-1.2.fc4 Firefox/1.0.7

Description of problem:
Enabling reverse video mode from the VT Options menu (ctrl + middle mousebutton) leaves cursor black together with background being black as well, making the cursor invisible.


Version-Release number of selected component (if applicable):
xterm-208-2.FC4

How reproducible:
Always

Steps to Reproduce:
1. start xterm
2. turn on "Enable Reverse Video" from the VT Options menu
3.
  

Actual Results:  Cursor colour is same as the background colour (both black).


Expected Results:  Earlier versions made the cursor colour different, white if I recall correctly.


Additional info:

[joyr@doors ~]$ xrdb -query | grep -i curs
*Scrollbar*Cursor:      left_ptr
*Scrollbar*cursorName:  left_ptr
Emacs*cursorColor:      Orchid
Xcursor.size:   24
Xcursor.theme:  Bluecurve
Xcursor.theme_core:     true
[joyr@doors ~]$
Comment 1 Jesse Thilo 2006-03-06 11:49:04 EST
Seconded, in a slightly different situation.  I use a white-on-black set of
defaults, and my cursor always turns black at some point (turning on reverse
video exposes the cursor).  This didn't happen in xterm-208-1.

$ xrdb -query | grep VT100
*VT100*backarrowKey:    false
*VT100*background:      black
*VT100*boldColors:      true
*VT100*boldFont:        false
*VT100*boldMode:        off
*VT100*colorBDMode:     off
*VT100*colorBLMode:     off
*VT100*colorULMode:     off
*VT100*cursorColor:     grey
*VT100*dynamicColors:   false
*VT100*eightBitInput:   false
*VT100*foreground:      grey
*VT100*geometry:        80x24
*VT100*jumpScroll:      true
*VT100*loginShell:      true
*VT100*ptyInitialErase: true
*VT100*reverseWrap:     true
*VT100*saveLines:       2500
*VT100*scrollBar:       true
*VT100*underLine:       on
*VT100*utf8:            true
Comment 2 Jason Vas Dias 2006-03-06 12:12:22 EST
Yes, I see the problem - this is because of the fix to bug 178302, which 
was a complaint about xterm not setting the cursor color if *vt100*cursorColor
is explicitly set to be the same as the foreground color . xterm was testing
if the cursorColor is the same as the foreground color, and not setting the
cursor to that color if so. But when ReverseVideo is enabled, the cursor color
IS the same as the foreground color by default, so xterm would not set the
cursor color to that value, leaving it the same as the background.
I think xterm's logic needs to be a bit more sophisticated than just refusing
to set the cursorColor if it is the same as the foreground . 
Perhaps xterm should only refuse to set the cursorColor to the foreground if
ReverseVideo is in effect.
I'll be fixing this with xterm-208-4.FC4 today .
Comment 3 Thomas E. Dickey 2006-03-06 19:45:30 EST
Something more complicated than what you're suggesting, but
taking that into account.  I've had a couple other complaints
about this recently, will look into a short #210 to address this
area.
Comment 4 Thomas E. Dickey 2006-03-07 07:05:35 EST
Looked into it - no: the bug is in a different place (changing
set_cursor_gcs is incorrect).  I'll add a call to set_cursor_gcs
from ReverseVideo instead.  Looks like this was an old bug exposed
by the changes to set_cursor_gcs rather than a new bug.
Comment 5 Jason Vas Dias 2006-03-07 17:08:18 EST
Many thanks Thomas - placed a call to set_cursor_gcs in ReverseVideo and the
problem is now fixed with xterm-208-4.FC4 , shortly to be released to FC-4
updates / testing. 

Comment 6 Fedora Update System 2006-03-07 23:42:46 EST
From User-Agent: XML-RPC

xterm-208-4.FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 7 Fedora Update System 2006-03-22 14:35:28 EST
xterm-208-4.FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.