Bug 1840 - /etc/rc.d/init.d/nfs probe not working properly
Summary: /etc/rc.d/init.d/nfs probe not working properly
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: knfsd   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-26 23:34 UTC by Michael K. Johnson
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-29 17:13:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael K. Johnson 1999-03-26 23:34:51 UTC
Linuxconf always wants to restart NFS. This is a bug in
/etc/rc.d/init.d/nfs as this sysv script is of type "probe".

Comment 1 Preston Brown 1999-03-29 16:46:59 UTC
as of knfsd-1.2-3, when nfs is stopped, /etc/rc.d/init.d/nfs probe
will correctly return 'start' not 'restart'. Do you mean you never get
the 'reload' to be returned?

Comment 2 Michael K. Johnson 1999-03-29 16:56:59 UTC
Does "/etc/rc.d/init.d/nfs probe" print nothing (not "nothing",
rather literally nothing at all) and return success when nothing
needs to be done because the configuration is up to date?

Comment 3 Michael K. Johnson 1999-03-29 17:01:59 UTC
Yes, even when nothing needs to be done, the probe command always
prints "restart"

Comment 4 Michael K. Johnson 1999-03-29 17:13:59 UTC
Fixed in knfsd-1.2-5


Note You need to log in before you can comment on or make changes to this bug.