Bug 18400 - Installer leaves machine in non-working state.
Installer leaves machine in non-working state.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-05 09:12 EDT by Matt Bottrell
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-04 10:20:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Bottrell 2000-10-05 09:12:52 EDT
Okay,

Here's as much information as I can provide.

I'm an old hand at RHL -- been using it since 3.0.3 days... and been in
Linux since '94.

Started the install... created boot images from the CD.  Use the boot.img
(the IDE CDROM was found on /dev/hdd -- so couldn't boot).

Hardware setup:

10/100 Tulip based ether card
Intel PII 400MHZ
2 x 16Gb IDE Seagate drives
2 x 128MB of SDRAM.
RIVA TNT 16MB video card.
ES1370 based sound card.
Panasonic 1.44MB floppy
Teac 48x CDROM IDE drive
PS/2 Intelli mouse.

(Reasonably stock standard hardware -- nothing too exotic).


This machine has been running successfully RH 6.2 prior.

Previous partitions were are such:

/
/data
/data/vm
/opt
/usr
/usr/local
/home
/tmp
/var

I did a fresh, custom install. (read as new -- NOT upgrade -- prefer that
method everytime!)

I formatted every partition besides /opt, /data, /data/vm, and /home.  The
rest I could afford to loose.

Fine, all hardware recognised...

The strange thing I notice however is that not all the packages I was used
to see appeared.

Items such as:

kernel (I could see the BOOT, SMP, and Enterprise ones -- however not the
single CPU kernel build).
items such as bash under shells (could see all the others).

Didn't think much of it at the time -- though --- hmmm maybe they are just
'default' settings and hidden from me ... okay.... 

Anyway -- I chose the Enterprise and SMP kernels just to be sure...
similiarly with other items -- there were plenty -- I just chose
replacements.... 

All dandy -- went through, it formatted, whizzed and even copied the
packages across (prompted for the 2nd CD-ROM and all).

However -- after the reboot....

-------This is what is seen -----------
   * Usual init of hardware -- sees everything fine... then...

VFS:  Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 40k freed  <-- all normal up to here.
Warning: unable to open an initial console.
<flashing line cursor>
-------------------------------------------


At this point the machine is frozen..... nothing works....

This is normally when init should kick in and the rc scripts are then read
after the inittab....
A mingetty is then normally fired so one can login.

Currently the machine sits in this state.  No VC's are avialable, no
keyboard input (can't control-alt-delete) -- nothing.

I can only use the Shift-PageUp feature -- which I've done -- and
everything has loaded 
correct...

I imagine some packages have either screwed permissions or a missing....
Any ideas?

I thought I might have stuffed something -- so I re-ran it several times. 
I even tried a workstation and a server default build (just to see if  I
could get one to type of build working).

All report the same....

Is there a problem with the boot.img and the installer?

Any help would be appreciated.  Could a response also be emailed to me so I
can check this bug request when a comment has been made.

Thank you in advance...

A normally happy RH User.... now not so happy....... 8-(


Regards,

MeB.
Comment 1 Michael Fulbright 2000-10-05 12:00:05 EDT
Did you happen to burn this CDROM yourself?
Comment 2 Matt Bottrell 2000-10-05 23:15:09 EDT
Yes I did burn the CDROM.

I've successfully burnt over 1,000 CDROM's and I know it has been successfully
burnt.  (It is automated via a script used to burn all CDs...)

I have even reburnt the CD twice... just to eliminate an issue with the burn.  I
have burnt all RH CD's since ISOs have been released....

I can see the CD is valid by mounting on other machines and reading through the
RPMS....

In addition -- the iso images have been mounted on loop back devices.

The isos' were obtained from
http://mirror.aarnet.edu.au/pub/linux/redhat/redhat-7.0/iso/  -- You may wish to
check them out.

However -- aarnet is Australia's largest mirror site and normally very reliable
(never had a fault).  In addition they mirror from RH.

Regards,

Matt.

Is there a known issue with the ISO's released from RH?
Comment 3 Michael Fulbright 2000-10-06 16:39:09 EDT
This looks like a kernel issue, reassigning.
Comment 4 Matt Bottrell 2000-10-23 18:27:19 EDT
Any movement on this?
Comment 5 Alan Cox 2000-10-27 13:04:35 EDT
Its not kernel. The situation described is the installer failing to install
stuff (in this case the dev rpm). This really smells of installer or hardware
and old releases work which strongly suggests an installer or cd problem.

Comment 6 Michael Fulbright 2000-11-10 12:31:35 EST
What steps are required so that we could try to reproduce this issue?
Comment 7 Michael Fulbright 2000-12-04 10:20:13 EST
Please reopen this report if you continue to have problems.

Note You need to log in before you can comment on or make changes to this bug.