Bug 1840106 - [Baremetal on IPI]: Master machines are not assigned to nodes
Summary: [Baremetal on IPI]: Master machines are not assigned to nodes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Bare Metal Hardware Provisioning
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.4.z
Assignee: Egor Lunin
QA Contact: Constantin Vultur
URL:
Whiteboard:
: 1840133 (view as bug list)
Depends On: 1835419
Blocks: 1771572 1801970 1809664 1813800 1813801
TreeView+ depends on / blocked
 
Reported: 2020-05-26 11:33 UTC by OpenShift BugZilla Robot
Modified: 2020-08-06 19:08 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-06 19:07:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
issue on UI (123.80 KB, image/png)
2020-07-01 10:46 UTC, Constantin Vultur
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift baremetal-operator pull 87 None closed [release-4.4] Bug 1840106: Backport get-hardware-details 2020-09-29 20:44:12 UTC
Github openshift installer pull 3656 None closed [release-4.4] Baremetal: Bug 1840106: Pull data from ironic inspector and annotate BareMetalHost 2020-09-29 20:44:18 UTC
Red Hat Product Errata RHBA-2020:3237 None None None 2020-08-06 19:08:27 UTC

Comment 1 Stephen Benjamin 2020-05-26 12:57:55 UTC
*** Bug 1840133 has been marked as a duplicate of this bug. ***

Comment 2 Jiri Tomasek 2020-06-17 12:40:48 UTC
Removing 4.5 targeted bugs from being block by this as this is 4.4 version.

Comment 9 Scott Dodson 2020-06-30 12:58:58 UTC
This should be verified against the latest 4.4 nightly which has the fix, not 4.4.10.

Comment 10 Constantin Vultur 2020-07-01 10:44:28 UTC
Deployed 4.4.0-0.nightly-2020-06-29-071755.

Cluster deployed successfully, still while checking the UI, the issue is still present

[kni@provisionhost-0-0 ~]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.4.0-0.nightly-2020-06-29-071755   True        False         12s     Cluster version is 4.4.0-0.nightly-2020-06-29-071755
[kni@provisionhost-0-0 ~]$ oc get co
NAME                                       VERSION                             AVAILABLE   PROGRESSING   DEGRADED   SINCE
authentication                             4.4.0-0.nightly-2020-06-29-071755   True        False         False      106s
cloud-credential                           4.4.0-0.nightly-2020-06-29-071755   True        False         False      63m
cluster-autoscaler                         4.4.0-0.nightly-2020-06-29-071755   True        False         False      28m
console                                    4.4.0-0.nightly-2020-06-29-071755   True        False         False      4m33s
csi-snapshot-controller                    4.4.0-0.nightly-2020-06-29-071755   True        False         False      28m
dns                                        4.4.0-0.nightly-2020-06-29-071755   True        False         False      47m
etcd                                       4.4.0-0.nightly-2020-06-29-071755   True        False         False      32m
image-registry                             4.4.0-0.nightly-2020-06-29-071755   True        False         False      29m
ingress                                    4.4.0-0.nightly-2020-06-29-071755   True        False         False      7m29s
insights                                   4.4.0-0.nightly-2020-06-29-071755   True        False         False      29m
kube-apiserver                             4.4.0-0.nightly-2020-06-29-071755   True        False         False      31m
kube-controller-manager                    4.4.0-0.nightly-2020-06-29-071755   True        False         False      45m
kube-scheduler                             4.4.0-0.nightly-2020-06-29-071755   True        False         False      44m
kube-storage-version-migrator              4.4.0-0.nightly-2020-06-29-071755   True        False         False      47m
machine-api                                4.4.0-0.nightly-2020-06-29-071755   True        False         False      29m
machine-config                             4.4.0-0.nightly-2020-06-29-071755   True        False         False      47m
marketplace                                4.4.0-0.nightly-2020-06-29-071755   True        False         False      29m
monitoring                                 4.4.0-0.nightly-2020-06-29-071755   True        False         False      6m6s
network                                    4.4.0-0.nightly-2020-06-29-071755   True        False         False      48m
node-tuning                                4.4.0-0.nightly-2020-06-29-071755   True        False         False      48m
openshift-apiserver                        4.4.0-0.nightly-2020-06-29-071755   True        False         False      28m
openshift-controller-manager               4.4.0-0.nightly-2020-06-29-071755   True        False         False      28m
openshift-samples                          4.4.0-0.nightly-2020-06-29-071755   True        False         False      26m
operator-lifecycle-manager                 4.4.0-0.nightly-2020-06-29-071755   True        False         False      47m
operator-lifecycle-manager-catalog         4.4.0-0.nightly-2020-06-29-071755   True        False         False      47m
operator-lifecycle-manager-packageserver   4.4.0-0.nightly-2020-06-29-071755   True        False         False      12m
service-ca                                 4.4.0-0.nightly-2020-06-29-071755   True        False         False      48m
service-catalog-apiserver                  4.4.0-0.nightly-2020-06-29-071755   True        False         False      48m
service-catalog-controller-manager         4.4.0-0.nightly-2020-06-29-071755   True        False         False      48m
storage                                    4.4.0-0.nightly-2020-06-29-071755   True        False         False      29m
[kni@provisionhost-0-0 ~]$ 

Moving back to ASSIGNED. 

Will attach screen capture shortly.

Comment 11 Constantin Vultur 2020-07-01 10:46:17 UTC
Created attachment 1699472 [details]
issue on UI

issue present with build 4.4.0-0.nightly-2020-06-29-071755

Comment 12 Stephen Benjamin 2020-07-01 11:24:14 UTC
Do you still have the cluster? Any chance you could do `oc get bmh -o yaml` and also attach a must-gather?

Comment 13 Constantin Vultur 2020-07-01 11:55:26 UTC
Hi Stephen,

Yes, I still have the cluster. Ping me on slack if you need connection details. 

I've placed the requested files on:  http://file.emea.redhat.com/~cvultur/bz1840106/

Let me know if there is something else needed.

Comment 14 Stephen Benjamin 2020-07-01 13:03:36 UTC
It looks like introspection didn't run on the control plane.  Introspection is turned on: https://github.com/openshift/installer/blob/release-4.4/data/data/baremetal/masters/main.tf#L6

However, there's no data in the BMH indicating inspection ran.

We'll have to deploy a 4.4 install and look at the bootstrap to figure out why, I'll get someone to look at this - I think we have enough info for now, thanks!

Comment 20 Constantin Vultur 2020-08-03 10:51:09 UTC
Deployed: 
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.4.0-0.nightly-2020-08-01-220435   True        False         10m     Cluster version is 4.4.0-0.nightly-2020-08-01-220435


Nodes page properly maps node to machines
Machine page properly maps machines to nodes
Bare Metal Hosts page properly maps to nodes 

This is now fixed. Moving to Verified

Comment 22 errata-xmlrpc 2020-08-06 19:07:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.4.16 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3237


Note You need to log in before you can comment on or make changes to this bug.