Bug 1840127 - [local-storage-diskmaker] Add some logs to help debugging when the storage admin adds non-disk file path to localvolume.spec.storageClassDevices[].devicePaths
Summary: [local-storage-diskmaker] Add some logs to help debugging when the storage ad...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.6.0
Assignee: Christian Huffman
QA Contact: Chao Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-26 12:19 UTC by Qin Ping
Modified: 2020-10-27 16:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Enhanced logging in the Local Storage Operator. Reason: Previously, the error messages were fairly generic, regardless of the cause of the error. Result: Additional details are provided when a LocalVolume object is created and the specified devices are either not found or invalid.
Clone Of:
Environment:
Last Closed: 2020-10-27 16:01:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift local-storage-operator pull 130 0 None closed Bug 1840127: Enhanced error message reporting 2021-02-03 17:16:30 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:01:27 UTC

Description Qin Ping 2020-05-26 12:19:28 UTC
Description of problem:
Add some logs to help debugging when the storage admin adds non-disk file path to localvolume.spec.storageClassDevices[].devicePaths

Version-Release number of selected component (if applicable):
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE 
STATUS
version   4.5.0-0.nightly-2020-05-25-052746   True        False         17h   
Cluster version is 4.5.0-0.nightly-2020-05-25-052746

$ oc get csv -n local-storage
NAME                                        DISPLAY         VERSION           
 REPLACES   PHASE
local-storage-operator.4.5.0-202005221637   Local Storage   4.5.0-202005221637
            Succeeded


How reproducible:
Always

Steps to Reproduce:
1. Create localvolume instance with non-disk filepath, such as dir(/tmp) or file.
2.
3.

Actual results:
No PVs are created, checked logs of diskmaker

$ oc logs ds/example-local-diskmaker -n local-storage
Found 3 pods, using pod/example-local-diskmaker-hxvrb
I0526 09:16:42.558543       1 diskmaker.go:24] Go Version: go1.13.4
I0526 09:16:42.558796       1 diskmaker.go:25] Go OS/Arch: linux/amd64
I0526 09:16:42.558805       1 diskmaker.go:26] local-storage-diskmaker Version: v4.5.0-202005221637-0-g6f887cd-dirty
E0526 09:16:47.720873       1 diskmaker.go:235] unable to find matching disk /dev/vdf
E0526 09:16:47.720954       1 diskmaker.go:159] found empty matching device list
E0526 09:16:52.715411       1 diskmaker.go:235] unable to find matching disk /dev/vdf
E0526 09:16:52.715456       1 diskmaker.go:159] found empty matching device list
E0526 09:16:57.712002       1 diskmaker.go:235] unable to find matching disk /dev/vdf
E0526 09:16:57.712045       1 diskmaker.go:159] found empty matching device list
E0526 09:17:02.712407       1 diskmaker.go:235] unable to find matching disk /dev/vdf
E0526 09:17:02.712451       1 diskmaker.go:159] found empty matching device list
E0526 09:17:07.714401       1 diskmaker.go:235] unable to find matching disk /dev/vdf
E0526 09:17:07.714444       1 diskmaker.go:159] found empty matching device list



Expected results:
Add some logs such as: only block device is supported here, /tmp is a directory.

Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:

Comment 7 Chao Yang 2020-07-24 10:27:19 UTC
E0724 07:25:56.962927       1 diskmaker.go:252] no file exists for specified device /dev/vde
E0724 07:25:56.962977       1 diskmaker.go:252] no file exists for specified device /dev/vdf

Comment 8 Chao Yang 2020-07-24 10:31:15 UTC
Passed on below version
oc get csv
NAME                                           DISPLAY         VERSION                 REPLACES   PHASE
local-storage-operator.4.6.0-202007221854.p0   Local Storage   4.6.0-202007221854.p0              Succeeded

oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-07-23-220427   True        False         7h57m   Cluster version is 4.6.0-0.nightly-2020-07-23-220427

Comment 10 errata-xmlrpc 2020-10-27 16:01:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.