Bug 1840139 - Container Command throws an error in Edit Health Checks Form
Summary: Container Command throws an error in Edit Health Checks Form
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Vikram Raj
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-26 13:00 UTC by Vikram Raj
Modified: 2020-07-13 17:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:41:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5561 0 None open Bug 1840139: fix Request Type Container Command throws an error in Edit Health Checks Form 2020-06-24 03:20:56 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:41:57 UTC

Description Vikram Raj 2020-05-26 13:00:09 UTC
Description of problem:
An error occurs on editing health checks when request type `Container Command` is selected from the dropdown.


Steps to reproduce:
1. Right-Click on a node on Topology having health checks added
2. Select `Edit Health Checks`
3. In the probe form, try selecting `Container Command`

Actual Results:
the page fails to load and a Type error is logged in the browser's console

Expected Results:
the probe form should load successfully

Comment 3 Gajanan More 2020-05-29 03:37:24 UTC
I have validated the bugzilla on:
Build: 4.5.0-0.nightly-2020-05-28-070355
Browser: Google Chrome Version 81.0.4044.129
Marking this as verified.

Comment 4 errata-xmlrpc 2020-07-13 17:41:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.