Bug 184015 - Need option to choose driver for graphical install
Need option to choose driver for graphical install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-04 19:55 EST by Alex Stewart
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-06 15:37:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex Stewart 2006-03-04 19:55:22 EST
Description of problem:

From what I can tell, there are kernel command-line options in the installer to 
choose video resolution, etc, but there seems to be no way at all to manually 
choose the X video driver used by the graphical installer (and the subsequent 
installed system).  I cannot perform a GUI install currently because anaconda 
chooses a broken driver for my video card; however, if I could manually tell 
anaconda to use the vesa driver instead, I would be able to use the graphical 
installer.

This wouldn't be as much of an issue except that there is significant 
functionality in the graphical installer (manually configuring LVM groups, etc) 
which simply does not exist in the text-mode one, which I would like to use but 
can't.

(If there is, in fact, already an option to do this, then please consider this 
a request for some better documentation of available anaconda options, as I 
can't find anything anywhere that says this is possible.)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2006-03-06 15:37:51 EST
Added a change so that you can boot with 'linux vesa' and get the vesa driver
instead of what gets probed.  Given the drivers we have, this is really the only
reasonable alternative and so a little saner than a generic "choose your own
driver" type thing.

Note You need to log in before you can comment on or make changes to this bug.