Bug 184016 - Yumex randomly crashes (sometime locks up X or the entire box)
Yumex randomly crashes (sometime locks up X or the entire box)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-04 20:59 EST by Neil Cherry
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-06 08:12:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dumpo yumex produced (667 bytes, text/plain)
2006-03-04 20:59 EST, Neil Cherry
no flags Details

  None (edit)
Description Neil Cherry 2006-03-04 20:59:10 EST
Description of problem:

Yumex suddenly dies (leaves dump).

Version-Release number of selected component (if applicable):
Yum Extender 0.99.9

How reproducible:
Random, but does lock up X sometime entire system. And I seem to be able to
reproduce this as often as a couple times a week.

Steps to Reproduce:
1. run yumex
2. go to uninstall or update
3. click a bunch of stuff to upgrade or uninstall
  
Actual results:
random crash, lockup of X or lockup of system but it does occur pretty often.

Expected results:
upgrade or install

Additional info:
I have 4 panes open in X #1 runs Firefox (1.5.0.1) with lots of tabs (10+),
Thunderbird (1.5) and a gnometerminal. #2 has a 5 tab gnometerminal, #3 left
open and #4 a 4 tab gnometerminal. I'm also running Mr. House (Perl, Home
Automation app), Samba, cups and the normal services.

$ uname -a
Linux cookie.uucp 2.6.15-prep #8 Mon Feb 13 19:05:02 EST 2006 i686 athlon i386
GNU/Linux
$ cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 6
model name      : AMD Athlon(tm) XP
stepping        : 2
cpu MHz         : 1725.833
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36
mmx fxsr sse syscall mmxext 3dnowext 3dnow
bogomips        : 3453.26
$ free
             total       used       free     shared    buffers     cached
Mem:        759436     626388     133048          0      22528     243420
-/+ buffers/cache:     360440     398996
Swap:      1024120        116    1024004
$ df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda2             36802176  23316568  11585984  67% /
/dev/hda1                63893     28769     31825  48% /boot
/dev/shm                379716         0    379716   0% /dev/shm
Comment 1 Neil Cherry 2006-03-04 20:59:11 EST
Created attachment 125652 [details]
Dumpo yumex produced
Comment 2 Neil Cherry 2006-03-04 21:22:15 EST
I've update yum, yum-utils and yumex, I can make yumex crash consistently.
Comment 3 Tim Lauridsen 2006-03-05 00:30:37 EST
I will take look at this error, i look like it happens when a package only have
one changelog entry.
Comment 4 Tim Lauridsen 2006-03-06 08:12:11 EST
I have fixed the cause of the trackback, it will be included in the next release.

Note You need to log in before you can comment on or make changes to this bug.