Bug 1840251 - Running wmcb.exe copies the files specified in the command to C:/k on windows
Summary: Running wmcb.exe copies the files specified in the command to C:/k on windows
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Windows Containers
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Mansi Kulkarni
QA Contact: gaoshang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-26 16:06 UTC by Mansi Kulkarni
Modified: 2020-10-27 16:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:01:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift windows-machine-config-operator pull 95 0 None closed Bug 1840251: Fix file copy destination for Windows 2020-08-24 16:53:48 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:01:19 UTC

Description Mansi Kulkarni 2020-05-26 16:06:22 UTC
Description of problem:

Running wmcb.exe copies the files specified in the wmcb command to C:/k folder on windows VM. Example running following command is copying cni.conf and cni folder to C:/K on windows VM: configureCNICmd := C:\\Temp\\wmcb.exe configure-cni --cni-dir=C:\\Temp\\cni\\ --cni-config=C:\\Temp\\cni\\cni.conf

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run the opeartor
2. RDP into windows VM
3. check the contents of C:/K folder on windows VM

Actual results:
C:/K folder contains cni folder and cni.conf file

Expected results:
C:/K folder should not contain cni folder and cni.conf file or any other additional files associated with running wmcb command.

Additional info:

Comment 1 Mansi Kulkarni 2020-05-26 16:39:18 UTC
This bug is being tracked by https://issues.redhat.com/browse/WINC-411

Comment 2 Aravindh Puthiyaparambil 2020-06-08 16:27:17 UTC
We should not be using C:\Temp for anything that we want preserved.

Comment 5 gaoshang 2020-08-26 03:05:57 UTC
This bug has been verified and passed on OCP 4.6.0-0.nightly-2020-08-24-110601, thanks.

Steps:
1. Run WMCO operator and bootstrap Windows node
2. SSH into Windows node
3. Check copied files location as expected

PS C:\k\cni> ls 
    Directory: C:\k\cni
Mode                LastWriteTime         Length Name
----                -------------         ------ ----
d-----        8/25/2020   1:56 PM                config
-a----        8/25/2020   1:56 PM        7533056 flannel.exe
-a----        8/25/2020   1:56 PM        3330048 host-local.exe
-a----        8/25/2020   1:56 PM        7989248 win-bridge.exe
-a----        8/25/2020   1:56 PM        7886848 win-overlay.exe

PS C:\k\cni> ls .\config\
    Directory: C:\k\cni\config
Mode                LastWriteTime         Length Name
----                -------------         ------ ----
-a----        8/25/2020   1:56 PM            394 cni.conf

PS C:\k> ls
    Directory: C:\k
Mode                LastWriteTime         Length Name
----                -------------         ------ ----
d-----        8/25/2020   1:53 PM                cni
d-----        8/25/2020   1:53 PM                etc
d-----        8/25/2020   1:53 PM                usr
-a----        8/25/2020   1:53 PM          10865 bootstrap-kubeconfig
-a----        8/25/2020   1:53 PM       47306752 hybrid-overlay-node.exe
-a----        8/25/2020   1:53 PM       44950016 kube-proxy.exe
-a----        8/25/2020   1:53 PM          10089 kubeconfig
-a----        8/25/2020   1:53 PM           5875 kubelet-ca.crt
-a----        8/25/2020   1:53 PM            739 kubelet.conf
-a----        8/25/2020   1:53 PM      111417856 kubelet.exe
-a----        8/25/2020   1:53 PM       14966272 wmcb.exe

PS C:\> ls .\Temp\
    Directory: C:\Temp
Mode                LastWriteTime         Length Name
----                -------------         ------ ----
-a----        8/25/2020   1:53 PM           5741 hns.psm1
-a----        8/25/2020   1:53 PM           1173 wget-ignore-cert.ps1

Comment 7 errata-xmlrpc 2020-10-27 16:01:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.