Bug 1840256 - Deselecting and selecting Application grouping throws exception on Firefox
Summary: Deselecting and selecting Application grouping throws exception on Firefox
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-26 16:14 UTC by Jeff Phillips
Modified: 2020-07-13 17:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.5.0-0.ci-2020-05-26-081827 Cluster ID: 2b906c42-8514-4828-a46d-f7b0e14136b8 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36
Last Closed: 2020-07-13 17:41:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5569 0 None closed Bug 1840256: Fix for re-display of EventSources with links in topology 2020-06-24 03:21:06 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:41:57 UTC

Description Jeff Phillips 2020-05-26 16:14:06 UTC
Description of problem:

Deselecting and selecting Application grouping throws exception and page ends up with white screen.

Version-Release number of selected component (if applicable):


How reproducible:

Only on Firefox

Steps to Reproduce:
1. Launch Developer console on Firefox browser
2. Switch to Developer perspective
3. Navigate to topology page & select a project which has Event source
4. Deselect & select `Event Sources` from Display options dropdown

Actual results:

Deselecting and selecting Event sources throws exception and page ends up with white screen.

Expected results:

On deselecting Event sources, all Event sources should hide & on Selecting Event sources, all Event sources should display.


Additional info:

Comment 3 spathak@redhat.com 2020-06-01 22:23:07 UTC
https://issues.redhat.com/browse/ODC-3942?focusedCommentId=14128816&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-14128816
Verified on build version: 4.5.0-0.ci-2020-05-29-203954
Browser version: Firefox 73

Comment 4 errata-xmlrpc 2020-07-13 17:41:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.