Bug 1840264 - error occurred deleting an application
Summary: error occurred deleting an application
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Sahil Budhwar
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-26 16:16 UTC by Sahil Budhwar
Modified: 2020-07-13 17:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:41:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
No error occurred deleting an application (374.44 KB, video/webm)
2020-06-11 09:50 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5573 0 None closed Bug 1840264: fixes: delete application error 2020-07-02 09:36:19 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:41:57 UTC

Description Sahil Budhwar 2020-05-26 16:16:24 UTC
Description of problem:
Deleting an application always shows an error even though after closing the modal the deletion seems to have completed correctly.

Steps to Reproduce:
1. go to add flow -> container image
2. enter external registry value `openshift/hello-openshift`
3. keep the rest of the form defaults and complete the form
4. from topology page select the application and choose `Delete Application`
5. Submit the form in the modal after filling out the text input with the name.

Actual results:
An error occurred while deleting application


Similar error occurred when deleting an application created by importing a container (dotnet) from the openshift namespace:


Expected results:
Deletion to work without error.

Reproducibility (Always/Intermittent/Only Once):
always

Build Details:
4.5.0-0.ci-2020-04-30-121321

Additional info:
To the user the deletion worked because there is no longer any workloads in topology.
Similar experience again with git import flow.

Comment 4 spathak@redhat.com 2020-06-11 09:50:08 UTC
Created attachment 1696705 [details]
No error occurred deleting an application

Comment 5 spathak@redhat.com 2020-06-11 12:45:31 UTC
Verified on build version:4.5.0-0.nightly-2020-06-10-224736
Browser version: chrome76

Comment 6 errata-xmlrpc 2020-07-13 17:41:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.