Bug 184041 - f-spot d-bus/selinux xception
f-spot d-bus/selinux xception
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: f-spot (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-05 06:01 EST by Mads Villadsen
Modified: 2009-03-22 14:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-22 13:59:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Villadsen 2006-03-05 06:01:45 EST
Description of problem:
When starting f-spot it outputs an error regarding selinux/dbus.

Version-Release number of selected component (if applicable):
selinux-policy-2.2.21-7
selinux-policy-targeted-2.2.21-7
f-spot-0.1.10-1
dbus-0.61-3


How reproducible:
Always

Steps to Reproduce:
1. Start f-spot from terminal
2. f-spot start, but shows this error:

[maxx@ice ~]$ f-spot
Starting new FSpot server
DBus.DBusException: An SELinux policy prevents this sender from sending this
message to this recipient (rejected message had interface "org.freedesktop.DBus"
member "Hello" error name "(unset)" destination "org.freedesktop.DBus")
in <0x0009f> DBus.Bus:GetBus (BusType busType)
in <0x00009> DBus.Bus:GetSessionBus ()
in <0x00013> FSpot.Core:get_Connection ()
in <0x0000d> FSpot.Core:RegisterServer ()
in <0x00349> FSpot.Driver:Main (System.String[] args)
Comment 1 Christopher Aillon 2006-03-06 17:24:54 EST
This ought to be fixed in latest rawhide.  Which version of mono-core are you using?
Comment 2 Mads Villadsen 2006-03-07 12:26:20 EST
mono-core-1.1.13.4-1

And it does indeed seem to be fixed now.
Comment 3 Mads Villadsen 2006-04-19 18:41:16 EDT
Just tried it again in an updated fedora core 5, and the error is still there.
Here are the versions I am using now:

mono-core-1.1.13.4-2
f-spot-0.1.10-1
selinux-policy-2.2.29-3.fc5
selinux-policy-targeted-2.2.29-3.fc5
dbus-0.61-3
Comment 4 Matthew Miller 2007-04-06 14:39:50 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 5 Mads Villadsen 2007-04-11 14:15:26 EDT
Works fine with F7T3
Comment 6 Matthew Miller 2007-04-11 14:17:57 EDT
thanks.
Comment 7 Trustin Lee 2009-03-22 13:48:06 EDT
Fedora 11 Rawhide seems to have a regression:

[trustin@vault ~]$ f-spot
[Info  02:44:01.236] Initializing DBus
[Info  02:44:01.354] Initializing Mono.Addins
pp SCAN: SetupDomain
[Info  02:44:03.051] Starting new FSpot server
XXXXX
System.Exception: org.freedesktop.DBus.Error.AccessDenied: Connection ":1.177" is not allowed to own the service "org.gnome.FSpot" due to SELinux policy
  at IBusProxy.RequestName (System.String flags, NameFlag ) [0x00000] 
  at NDesk.DBus.Bus.RequestName (System.String name, NameFlag flags) [0x00000] 
  at FSpot.Core.RegisterServer () [0x00000] 
  at FSpot.Driver.Main (System.String[] args) [0x00000] 
XXXXX
[Warn  02:44:03.114] Can't get a connection to the dbus. Trying again...
[Info  02:44:03.115] Starting new FSpot server
[Warn  02:44:03.115] Can't get a connection to the dbus. Trying again...
[Info  02:44:03.116] Starting new FSpot server
[Warn  02:44:03.116] Can't get a connection to the dbus. Trying again...
[Info  02:44:03.116] Starting new FSpot server
[Warn  02:44:03.116] Can't get a connection to the dbus. Trying again...
[Info  02:44:03.117] Starting new FSpot server
[Warn  02:44:03.117] Can't get a connection to the dbus. Trying again...
[Info  02:44:03.118] Starting new FSpot server
[Warn  02:44:03.118] Can't get a connection to the dbus. Trying again...
[Error 02:44:03.118] Sorry, couldn't start F-Spot

Versions:

f-spot-0.5.0.3-7.fc11.x86_64
mono-core-2.4-9.RC1.fc11.x86_64
selinux-policy-targeted-3.6.8-3.fc11.noarch
selinux-policy-3.6.8-3.fc11.noarch
dbus-1.2.4.4permissive-4.fc11.x86_64
Comment 8 Trustin Lee 2009-03-22 13:49:14 EDT
ndesk-dbus version is:
ndesk-dbus-0.6.1a-4.fc11.x86_64
Comment 9 Christopher Aillon 2009-03-22 13:59:28 EDT
This bug was fixed three years ago and six releases ago.  While your symptoms may be similar (or even exactly the same) the cause is most certainly different and thus a different bug.  Restoring back to closed.

Please file a new bug for this issue.  It will also have the benefit of being seen by the people who maintain f-spot today as opposed to 3 years ago.  :-)
Comment 10 Trustin Lee 2009-03-22 14:26:15 EDT
Very true.  Actually, I've just found the bug has been filed already - #491480
Sorry for the noise!

Note You need to log in before you can comment on or make changes to this bug.