Bug 1840432 - [abrt] calibre: __init__(): server.py:109:__init__:AttributeError: 'NoneType' object has no attribute 'cancel'
Summary: [abrt] calibre: __init__(): server.py:109:__init__:AttributeError: 'NoneType'...
Keywords:
Status: CLOSED DUPLICATE of bug 1840780
Alias: None
Product: Fedora
Classification: Fedora
Component: calibre
Version: 32
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:1530bab30d41b44b8a0fb3fbdd6...
: 1841124 1841357 1842914 1891323 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-26 22:53 UTC by Suvayu
Modified: 2020-10-25 16:21 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-29 22:45:51 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (853 bytes, text/plain)
2020-05-26 22:53 UTC, Suvayu
no flags Details
File: cgroup (351 bytes, text/plain)
2020-05-26 22:53 UTC, Suvayu
no flags Details
File: cpuinfo (2.39 KB, text/plain)
2020-05-26 22:53 UTC, Suvayu
no flags Details
File: environ (3.09 KB, text/plain)
2020-05-26 22:53 UTC, Suvayu
no flags Details
File: mountinfo (3.99 KB, text/plain)
2020-05-26 22:53 UTC, Suvayu
no flags Details
File: namespaces (172 bytes, text/plain)
2020-05-26 22:53 UTC, Suvayu
no flags Details
File: open_fds (1.94 KB, text/plain)
2020-05-26 22:53 UTC, Suvayu
no flags Details

Description Suvayu 2020-05-26 22:53:36 UTC
Description of problem:
I tried to open calibre from the menu (and from the terminal)

Version-Release number of selected component:
calibre-4.13.0-1.fc32

Additional info:
reporter:       libreport-2.13.1
cmdline:        /usr/bin/python3 /usr/bin/calibre --detach
crash_function: __init__
exception_type: AttributeError
executable:     /usr/bin/calibre
interpreter:    python3-3.8.3-1.fc32.x86_64
kernel:         5.6.14-300.fc32.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
server.py:109:__init__:AttributeError: 'NoneType' object has no attribute 'cancel'

Traceback (most recent call last):
  File "/usr/bin/calibre", line 20, in <module>
    sys.exit(calibre())
  File "/usr/lib64/calibre/calibre/gui_launch.py", line 72, in calibre
    main(args)
  File "/usr/lib64/calibre/calibre/gui2/main.py", line 542, in main
    listener = create_listener()
  File "/usr/lib64/calibre/calibre/gui2/main.py", line 513, in create_listener
    return Listener(address=gui_socket_address())
  File "/usr/lib64/calibre/calibre/utils/ipc/server.py", line 109, in __init__
    self._listener._unlink.cancel()
AttributeError: 'NoneType' object has no attribute 'cancel'

Local variables in innermost frame:
self: <calibre.utils.ipc.server.LinuxListener object at 0x7f178b02cee0>
args: ()
kwargs: {'address': '\x00suvali-calibre-gui.socket'}

Comment 1 Suvayu 2020-05-26 22:53:39 UTC
Created attachment 1692456 [details]
File: backtrace

Comment 2 Suvayu 2020-05-26 22:53:41 UTC
Created attachment 1692457 [details]
File: cgroup

Comment 3 Suvayu 2020-05-26 22:53:42 UTC
Created attachment 1692458 [details]
File: cpuinfo

Comment 4 Suvayu 2020-05-26 22:53:44 UTC
Created attachment 1692459 [details]
File: environ

Comment 5 Suvayu 2020-05-26 22:53:46 UTC
Created attachment 1692460 [details]
File: mountinfo

Comment 6 Suvayu 2020-05-26 22:53:47 UTC
Created attachment 1692461 [details]
File: namespaces

Comment 7 Suvayu 2020-05-26 22:53:49 UTC
Created attachment 1692462 [details]
File: open_fds

Comment 8 David Sastre Medina 2020-05-27 10:42:59 UTC
I'm getting a slightly different error message:

$ calibre-debug -g
QSocketNotifier: Can only be used with threads started with QThread
calibre 4.13  embedded-python: False is64bit: True
Linux-5.6.13-300.fc32.x86_64-x86_64-with-glibc2.2.5 Linux ('64bit', 'ELF')
('Linux', '5.6.13-300.fc32.x86_64', '#1 SMP Thu May 14 22:51:37 UTC 2020')
Python 3.8.3
Interface language: None
Successfully initialized third party plugins: Extract ISBN (1, 4, 4)
Turning on automatic hidpi scaling
devicePixelRatio: 1.0
logicalDpi: 96.0 x 96.0
physicalDpi: 157.31612903225806 x 161.36470588235292
Using calibre Qt style: True
Traceback (most recent call last):
  File "/usr/bin/calibre-debug", line 20, in <module>
    sys.exit(main())
  File "/usr/lib64/calibre/calibre/debug.py", line 276, in main
    calibre(['calibre'] + args[1:])
  File "/usr/lib64/calibre/calibre/gui_launch.py", line 72, in calibre
    main(args)
  File "/usr/lib64/calibre/calibre/gui2/main.py", line 542, in main
    listener = create_listener()
  File "/usr/lib64/calibre/calibre/gui2/main.py", line 513, in create_listener
    return Listener(address=gui_socket_address())
  File "/usr/lib64/calibre/calibre/utils/ipc/server.py", line 109, in __init__
    self._listener._unlink.cancel()
AttributeError: 'NoneType' object has no attribute 'cancel'

Comment 9 Suvayu 2020-05-27 16:12:09 UTC
Why do you say slightly different?  The traceback looks identical to me.

Comment 10 David Sastre Medina 2020-05-27 16:23:42 UTC
The line:

QSocketNotifier: Can only be used with threads started with QThread

does not appear in your traceback.

Comment 11 Suvayu 2020-05-28 08:54:19 UTC
Hmm, I filed this ticket with abrt. When I tried to repeat your stacktrace with the same command line as you, I don't see that line.  Is it a DE specific warning?  The 'Q' in the name leads me to guess you are on KDE.  I'm on XFCE.

Comment 12 David Sastre Medina 2020-05-28 09:04:32 UTC
This is on GNOME.

Comment 13 seb 2020-05-28 12:36:52 UTC
*** Bug 1841124 has been marked as a duplicate of this bug. ***

Comment 14 Paul DeStefano 2020-05-28 21:27:08 UTC
Similar problem has been detected:

Just tried to start calibre from dash

reporter:       libreport-2.13.1
cgroup:         0::/user.slice/user-13013.slice/user@13013.service/gnome-launched-calibre-gui.desktop-277384.scope
cmdline:        /usr/bin/python3 /usr/bin/calibre --detach
crash_function: __init__
exception_type: AttributeError
executable:     /usr/bin/calibre
interpreter:    python3-3.8.3-1.fc32.x86_64
kernel:         5.7.0-0.rc7.1.fc32.x86_64
package:        calibre-4.13.0-1.fc32
reason:         server.py:109:__init__:AttributeError: 'NoneType' object has no attribute 'cancel'
runlevel:       N 5
type:           Python3

Comment 15 Paul DeStefano 2020-05-28 21:42:50 UTC
Calibre worked less than a day ago.  I did a dnf update since then, but it looks like there was a core python3 update that I got.

python3-3.8.3-1.fc32.x86_64.

Not sure what changed, though.  Pkg changelog just says rebased to 3.8.3, but it was working with rc1, so that's confusing.

Comment 16 Paulo 2020-05-28 23:35:15 UTC
*** Bug 1841357 has been marked as a duplicate of this bug. ***

Comment 17 Kevin Fenzi 2020-05-29 22:45:51 UTC

*** This bug has been marked as a duplicate of bug 1840780 ***

Comment 18 Alejandro 2020-06-02 11:41:43 UTC
*** Bug 1842914 has been marked as a duplicate of this bug. ***

Comment 19 Adolfo Guerrero 2020-10-25 16:21:26 UTC
*** Bug 1891323 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.