Bug 184048 - Support upgrade from 7.1 to 1.x
Support upgrade from 7.1 to 1.x
Status: CLOSED NEXTRELEASE
Product: 389
Classification: Community
Component: Admin (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-05 09:06 EST by Graham Leggett
Modified: 2015-01-04 18:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 11:50:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2006-03-05 09:06:34 EST
After doing an RPM upgrade from v7.1 to v1.0.2, the setup program is run to
finish the upgrade.

The setup hangs like so:

Converting slapd-gatekeeper.domain.com to new format password file . . .
Copying new schema ldiffiles . . .
Starting slapd-gatekeeper.domain.com . . .

ps shows a process called "ns-update" that is hanging around doing nothing.

Running all of this through strace finds that an error is thrown when the
upgrade process finds that the certdb files in alias are not owned by the ldap user.

Fixing the ownership problem manually and running setup again results in this:

Starting slapd-gatekeeper.domain.com . . .

NMC_ErrInfo:
NMC_STATUS: -2

Start Slapd Starting Slapd server reconfiguration.
Fatal Slapd ERROR: Ldap authentication failed for url
ldap://gatekeeper.domain.com:636/o=NetscapeRoot user id admin (151:Unknown error.)
Configuring Administration Server...
InstallInfo: Apache Directory "ApacheDir" is missing.

You can now use the console.  Here is the command to use to start the console:
cd /opt/fedora-ds
./startconsole -u admin -a http://gatekeeper.domain.com:390/

INFO Finished with setup, logfile is setup/setup.log

(The error "151:Unknown error" boggles the brain. If the software thinks the
error is unknown I shudder to think how the administrator is expected to know
what the error was, but regardless...)

At this point the LDAP server seems to be running correctly, but the admin
server is hosed.

Looking in the admin-serv/config directory, the original magnus.conf files are
present, no upgrade has happened.

So far it looks like upgrading from v7.1 to v1.0.2 is impossible, the only
option is to reinstall the DS from scratch.
Comment 1 Rich Megginson 2006-03-06 10:10:40 EST
Upgrade from 7.1 is not supported.  This is mainly due to the fact that the
admin server is completely different in 1.x.  It might be possible to get it
working but I'm not sure where to begin.
Comment 2 Graham Leggett 2006-03-06 14:10:06 EST
Upgrading from v7.1 is probably not worth the effort in supporting, however at
the very least the setup program should detect that httpd.conf (or whatever
signature file belongs to the admin server) is missing, and should go through
the bit of install that gets the admin server working.

Comment 3 Rich Megginson 2007-10-05 11:50:06 EDT
Fedora DS 1.1 supports upgrade/migration from 7.1 to 1.1

Note You need to log in before you can comment on or make changes to this bug.