Bug 18405 - init.d/autofs is broken for NIS automounter maps
Summary: init.d/autofs is broken for NIS automounter maps
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: autofs   
(Show other bugs)
Version: 7.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-05 14:46 UTC by Jay Berkenbilt
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-06 01:32:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay Berkenbilt 2000-10-05 14:46:09 UTC
In /etc/rc.d/init.d/autofs, the function getmounts() does nothing unless
/etc/auto.master exists.  The function getrawmounts() on the other hand
knows that if /etc/auto.master doesn't exist that it should look in NIS
instead.

Just removing this condition seems to fix the problem fine.  I'm not sure
why it's even there.  I don't have Pinstripe anymore, but it seems to me
that this problem was not present in the pinstripe release since I used
autofs via NIS fine there.

My trivial patch is attached.

-----------------------------------------------------------
--- autofs.qdist        Wed Aug 23 14:28:36 2000
+++ autofs      Tue Oct  3 08:21:55 2000
@@ -94,8 +94,6 @@
 #
 # Check for local maps to be loaded
 #
-if [ -f /etc/auto.master ]
-then
     knownmaps=" "
     getrawmounts | (
        while read dir map options
@@ -152,7 +150,6 @@
             knownmaps=" $dir/ $knownmaps"
        done
     )
-fi
 }
 
 #
----------------------------------------------------------

Comment 1 Thilo Mezger 2000-10-05 18:54:58 UTC
Well, I thought this this was a feature and not a bug.  Before, you always had
to remove /etc/auto.* to get your maps from NIS but now it even gets my NIS maps
when I have those files in /etc.

This means, I now don't even have to remove the files to get maps from NIS as I
always had to do RHL 6.x.


Comment 2 Nalin Dahyabhai 2000-10-06 01:32:46 UTC
That particular part of the patch we apply to the init script must have fallen
out at some point.  It will be re-added.  Thanks!

Comment 3 Nalin Dahyabhai 2001-01-12 04:07:58 UTC
The current incarnation of the repeatedly-modified init script now scans
/etc/nsswitch.conf, so this should be Right for everyone.


Note You need to log in before you can comment on or make changes to this bug.