Bug 184056 - glibc catching heap corruption in libgcj
glibc catching heap corruption in libgcj
Status: CLOSED DUPLICATE of bug 183895
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
powerpc Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-05 11:37 EST by Anthony Green
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-05 11:39:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Green 2006-03-05 11:37:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I'm having problems building my Extras packages on PPC.  I get errors like
this...

*** glibc detected *** /usr/lib/jvm/java/bin/java: free(): invalid pointer: 0xf2d299f8 ***
======= Backtrace: =========
/lib/libc.so.6[0xe5f6824]
/lib/libc.so.6(__libc_free+0xc8)[0xe5f9cc8]
/usr/lib/../lib/libgcj.so.7(_Jv_Free+0x24)[0xf1abc24]
/usr/lib/../lib/libgcj.so.7(_Z9_Jv_ZFreePvS_+0x28)[0xf1f9b88]
/usr/lib/../lib/libz.so.1(inflateEnd+0x78)[0xe738d38]
/usr/lib/../lib/libgcj.so.7(_ZN4java4util3zip8Inflater3endEv+0x38)[0xf1f9de8]
/usr/lib/../lib/libgcj.so.7(_ZN4java4util3zip8Inflater8finalizeEv+0x28)[0xf50d328]
/usr/lib/../lib/libgcj.so.7(_Z18_Jv_FinalizeObjectPN4java4lang6ObjectE+0x30)[0xf1ec0c0]


Here are two logs..

http://buildsys.fedoraproject.org/logs/fedora-development-extras/5860-jogl-1.1.1-14.fc5/ppc/build.log

http://buildsys.fedoraproject.org/logs/fedora-development-extras/5859-kawa-1.8-5.fc5/ppc/build.log


overholt says he can't build Eclipse on PPC in rawhide either.


AG


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Try to build the kawa SRPM in rawhide.
2.
3.
  

Additional info:
Comment 1 Jakub Jelinek 2006-03-05 11:39:25 EST

*** This bug has been marked as a duplicate of 183895 ***

Note You need to log in before you can comment on or make changes to this bug.