Bug 184058 - Need docs for admin server ssl pin file
Summary: Need docs for admin server ssl pin file
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Directory Server
Classification: Red Hat
Component: Documentation   
(Show other bugs)
Version: 6.21
Hardware: All
OS: Linux
high
medium
Target Milestone: DSDocs
: ---
Assignee: Deon Ballard
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Keywords: Documentation, Reopened
Depends On:
Blocks: 152373 240316
TreeView+ depends on / blocked
 
Reported: 2006-03-05 17:22 UTC by Graham Leggett
Modified: 2015-01-04 23:19 UTC (History)
1 user (show)

Fixed In Version: 8.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 21:51:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Graham Leggett 2006-03-05 17:22:17 UTC
According to the docs at
http://directory.fedora.redhat.com/wiki/Howto:SSL#Starting_the_Server_with_SSL_enabled:

"If you do not have PIN file, it will prompt you for the password you used to
create the server cert."

Nowhere in the docs does it tell you what this PIN file is called, or which
directory the PIN file needs to be installed into, or exactly what (apart from
the PIN) needs to go into the PIN file.

Comment 1 Rich Megginson 2006-03-06 15:11:21 UTC
See http://directory.fedora.redhat.com/wiki/Howto:SSL#Script

Comment 3 Rich Megginson 2007-10-05 15:52:56 UTC
Brian, I'm not sure where the Admin Server stuff is documented, perhaps in the
Managing with Console doc.  But somewhere we need to document the format of the
password/pin file for Admin Server because it is different than Directory Server
and stored in a different place in the upcoming version.

Comment 5 Brian Forte 2007-10-30 16:12:02 UTC
Incorporated this into Encryption Keys section of Chapter 4 of Admin Guide.

Comment 6 Deon Ballard 2007-11-01 17:31:46 UTC
First, this isn't in the encryption keys section as the docs stand. Secondly,
this does not belong in that section; the encryption keys section relates to
encrypting database information as its stored in the database; there's nothing
there that relates to the Console, SSL, or the admin server. The better location
is either the basic "starting the console" section in chapter 1 (intro to the
DS) or using the DS, ADS, and Console with SSL in chapter 11 (managing ssl).

Reopening.

Comment 7 Deon Ballard 2007-12-04 23:08:10 UTC
I believe this is addressed in the beta admin guide now (as of 11/16, actually)
in the "Creating a Password File" section of the SSL chapter:
http://www.redhat.com/docs/manua-ls/dir-server/ag/8.0/Starting_the_Server_with_SSL_Enabled-Creating_a_Password_File.html

All of the sections dealing with starting the server in SSL now reference that
section, too. See the last step of
http://engineering.redhat.com/docbot/en-US/Red_Hat_Directory_Server/0/html/Administration_Guide/Starting_the_Server_with_SSL_Enabled-Enabling_SSL_Only_in_the_DS.html.

Comment 8 Deon Ballard 2007-12-04 23:08:48 UTC
I believe this is addressed in the beta admin guide now (as of 11/16, actually)
in the "Creating a Password File" section of the SSL chapter:
http://www.redhat.com/docs/manuals/dir-server/ag/8.0/Starting_the_Server_with_SSL_Enabled-Creating_a_Password_File.html

All of the sections dealing with starting the server in SSL now reference that
section, too. See the last step of
http://engineering.redhat.com/docbot/en-US/Red_Hat_Directory_Server/0/html/Administration_Guide/Starting_the_Server_with_SSL_Enabled-Enabling_SSL_Only_in_the_DS.html.

Comment 9 Deon Ballard 2008-02-15 21:51:05 UTC
CLosing review bugs and content bugs that were fixed in the 8.0 release for the
install, admin, and CLI guides.


Note You need to log in before you can comment on or make changes to this bug.